[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] can not mount GFS, "no such device"



Diamond Li wrote:
Since I have no idea about you guys OS version. From my version,
RH5.4, system is using
gfs2 kernel module, so I guess I have to use mkfs.gfs2 to create gfs2
file system.  However, I didn't see any RH5.4 document pointing
this(or I missed it out).

I suspect most documentation still doesn't mention GFS2 since it is still quite new and not far on it's maturity curve. GFS1, OTOH, has been around for a long time and is what is expected to be in production at the moment. FYI, I use RHEL/CentOS 5.x on my systems, most are now updated to 5.4 (as was the example I ran to test what you reported).

There are two separate kernel modules: gfs and gfs2. gfs requires gfs2 (some of the low level dependencies were moved there a long time ago), but working with GFS1 requires the gfs kernel module. If you haven't got gfs loaded (but do have gfs2 loaded) that would explain why you were having difficulties mounting a GFS1 file system (but GFS2 worked fine).

Your lsmod information seems consistent with this theory.

If you guys have the same configuration, that means GFS tools is
unstable because the only change I did is using different command.

See previous paragraph for gfs vs. gfs2.

Same as the problem I encountered using lvcreate, on the first day it
always hangs up, but in next morning, it executed successfully without
any changes. It sounds impossible but this is the truth.

Just to make sure - I take it you are aware that lvm (the non-cluster version) is different to clvm (the cluster-aware version)? You aren't using the non-cluster lvm for a cluster volume, are you?

Gordan


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]