[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] Failure to use fence_node with APC switches after 5.3 update



Is there any updates on this, even after suggested changes were applied per RH ticket in cluster.conf I still get the error.

On Thu, Feb 19, 2009 at 5:04 PM, Alan A <alan zg gmail com> wrote:

1896886



But RH says they found a work around by putting outlet number instead of the name of the port on the port= value in the cluster.conf.  I still get same result - which is garbage. I dont know the Bugzilla number.





On Thu, Feb 19, 2009 at 10:20 AM, Marek 'marx' Grác <mgrac redhat com> wrote:
Hi,


Alan A wrote:
Thanks Marx - I opened a ticket with RH support regarding this here are the details:


Can you tell me a ticket/bugzilla number? So I can fix it before it escaletes to me :)

m,


Hardware Factory
Model Number: AP7921 Serial Number: ZA0827009651 Hardware Revision: B2 Manufacture Date: 07/02/2008 MAC Address: xxxxxxxx Management Uptime: 7 Days 4 Hours 13 Minutes   Application Module;
Name: rpdu Version: v3.5.8 Date: 06/25/2008 Time: 12:31:09   APC OS (AOS)
Name: aos Version: v3.5.9 Date: 05/23/2008 Time: 11:54:45
-------------

fence_node -V
fence_node 2.0.98 (built Dec  3 2008 16:34:08)
Copyright (C) Red Hat, Inc.  2004  All rights reserved.


On Wed, Feb 18, 2009 at 4:28 AM, Marek Grac <mgrac redhat com <mailto:mgrac redhat com>> wrote:

   Hi,

   Alan A wrote:

        I just uped everything to RHEL 5.3 and this is what I get
       when trying to "fence_node nodename":
         [root fendev03 ~]# fence_node fendev04.xxxxxxxxx.com
       <http://fendev04.xxxxxxxxx.com> <http://fendev04.xxxxxxxxx.com>


       agent "fence_apc" reports: Traceback (most recent call last):
        File "/sbin/fence_apc", line 207, in ?
          main()
        File "/sbin/fence_apc", line 191, in main
          fence_action(conn, options, set_power_status, get_power_status)
        File "/usr/lib/fence/fencing.py", line 355, in fence_a
       agent "fence_apc" reports: ction
          status = get_power_fn(tn, options)
        File "/sbin/fence_apc", line 82, in get_power_status
          status = re.compile("\s*"+options["-n"]+"-.*(ON|OFF)",
       re.IGNORECASE).search(result).group(1)
       AttributeError: 'NoneType' object has no attribute 'group
       agent "fence_apc" reports: '
         Any opinions on this?

   Fence agent was not able to get status of device. Please create
   bug and put there name of APC device, firmware version, verbose
   output (use fence_apc -h for help: it will looks like 'fence_apc
   -l login -p passw -a address -o status -n portno -v' ) . I believe
   that it can be fixed very fast with these information.

   marx,

   --
   Linux-cluster mailing list
   Linux-cluster redhat com <mailto:Linux-cluster redhat com> ------------------------------------------------------------------------




--
Alan A.



--
Alan A.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]