[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Linux-cluster] ipmi activates session, but no talk.



Hi.

I'm trying to set up ipmi (1.5) management using the bmc on ibm
eserver326 machines. Yes, these machines are old.

So far, I've been able to access the bmc with ipmitool, and configure it
as correctly as I could for remote access.

When trying to access it from afar, I successfully activate a session,
but further requests are unanswered.

Some dumps of ipmitool commands are included below.

If anybody has an idea of what's going on, that would be greatly
appreciated.

I might also try to flash the bmc firmware, as it seems that ibm released
a newer firmware for these servers. But I'm already a bit puzzled by
the situation so far.

Thanks,

E.

I'm trying to access the bmc with IP 152.81.4.81 from the host with IP
152.81.3.83. The BMC piggies-back on the eth0 NIC which has IP
152.81.3.81 for the system. Thus the BMC and the system both have
different MAC and IPs. Seems to work fine as some kind of conversation
occurs.

Here's the output of a remote ipmi request:

[root cassandre ~]# IPMI_PASSWORD=xxx ipmitool -vvI lan -L USER -H 152.81.4.81 -E mc info
ipmi_lan_send_cmd:opened=[0], open=[4490512]
IPMI LAN host 152.81.4.81 port 623
Sending IPMI/RMCP presence ping packet
ipmi_lan_send_cmd:opened=[1], open=[4490512]
Channel 01 Authentication Capabilities:
  Privilege Level : USER
  Auth Types      : MD5 
  Per-msg auth    : disabled
  User level auth : disabled
  Non-null users  : enabled
  Null users      : enabled
  Anonymous login : disabled

Proceeding with AuthType MD5
ipmi_lan_send_cmd:opened=[1], open=[4490512]
Opening Session
  Session ID      : 751168e4
  Challenge       : e44e37374801833f77701411992dae25
  Privilege Level : USER
  Auth Type       : MD5
ipmi_lan_send_cmd:opened=[1], open=[4490512]

Session Activated
  Auth Type       : MD5
  Max Priv Level  : USER
  Session ID      : 751168e4
  Inbound Seq     : 00000001

        opened=[1], open=[4490512]
  No response from remote controller
Get Device ID command failed
ipmi_lan_send_cmd:opened=[1], open=[4490512]
  No response from remote controller
Close Session command failed

On the machine I'm trying to talk to, I have in particular:

[root achille ~]# ipmitool -I open session info all
[...]
session handle                : 255
slot count                    : 4
active sessions               : 1
user id                       : 1
privilege level               : USER
session type                  : IPMIv1.5
channel number                : 0x01
console ip                    : 152.81.3.83
console mac                   : 00:00:00:00:00:00
console port                  : 60599
[...]

[root achille ~]# /usr/bin/ipmitool -I open lan print 
Set in Progress         : Set Complete
Auth Type Support       : NONE MD5 PASSWORD 
Auth Type Enable        : Callback : MD5 
                        : User     : MD5 
                        : Operator : MD5 
                        : Admin    : MD5 
                        : OEM      : NONE MD5 PASSWORD 
IP Address Source       : Static Address
IP Address              : 152.81.4.81
Subnet Mask             : 255.255.240.0
MAC Address             : 00:0d:60:18:7c:47
SNMP Community String   : public
IP Header               : TTL=0x00 Flags=0x00 Precedence=0x00 TOS=0x00
Default Gateway IP      : 152.81.1.1
Default Gateway MAC     : 00:13:5f:89:14:00
Backup Gateway IP       : 192.168.0.2
Backup Gateway MAC      : 00:00:00:00:00:02
Cipher Suite Priv Max   : Not Available

[root achille ~]# ipmitool user  list  1
ID  Name             Callin  Link Auth  IPMI Msg   Channel Priv Limit
1                    true    false      true       ADMINISTRATOR
2   root             true    true       true       OPERATOR
3   USERID           true    true       true       ADMINISTRATOR
4   OEM              true    true       true       OEM

[root achille ~]# ipmitool -I open channel info 1
Channel 0x1 info:
  Channel Medium Type   : 802.3 LAN
  Channel Protocol Type : IPMB-1.0
  Session Support       : multi-session
  Active Session Count  : 1
  Protocol Vendor ID    : 7154
  Volatile(active) Settings
    Alerting            : disabled
    Per-message Auth    : disabled
    User Level Auth     : disabled
    Access Mode         : always available
  Non-Volatile Settings
    Alerting            : disabled
    Per-message Auth    : disabled
    User Level Auth     : disabled
    Access Mode         : always available


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]