[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Linux-cluster] lvm2: cluster request failed: Unknown error 65538



Hello,
by mistake I previously sent this to fedora-list.
I resend to the appropriate list I wanted...
Excuse in advance for eventual cross-posting effects for anyone...

fedora11 x86_64 with lvm2, device-mapper and related packages updated at :
lvm2-2.02.48-1.fc11.x86_64
lvm2-cluster-2.02.48-1.fc11.x86_64
device-mapper-1.02.33-1.fc11.x86_64
device-mapper-libs-1.02.33-1.fc11.x86_64

I have 2 VGs: vg_virtfed that is a system vg (with root lv ans swap
lv) and vg_qemu01 that is a clustered vg.
At the moment only one node active

[root virtfed ~]# service clvmd status
clvmd (pid 2581) is running...
active volumes: centos53 centos53_cldisk1 centos53_cldisk2
centos53_disk2 centos53_node02 centos53_node02_disk2 centos53_qdisk
test_vm_drbd w2k3_01 lv_root lv_swap

- it is strange that between the active volumes I have also the ones
owned by vg_virtfed, that is not a clustered vg
vgs command gives

[root virtfed ~]# cman_tool status
Version: 6.2.0
Config Version: 3
Cluster Name: kvm
Cluster Id: 773
Cluster Member: Yes
Cluster Generation: 196
Membership state: Cluster-Member
Nodes: 1
Expected votes: 1
Total votes: 1
Node votes: 1
Quorum: 1
Active subsystems: 10
Flags: 2node HaveState
Ports Bound: 0 177
Node name: kvm1
Node ID: 1
Multicast addresses: 239.192.3.8
Node addresses: 192.168.10.1

I have no services or filesystem on cluster. Only the infra with cman and clvmd
[root virtfed ~]# clustat
Cluster Status for kvm @ Wed Jul 22 16:00:14 2009
Member Status: Quorate

 Member Name                                             ID   Status
 ------ ----                                             ---- ------
 kvm1                                                        1 Online, Local
 kvm2                                                        2 Offline


[root virtfed ~]# vgs
  cluster request failed: Unknown error 65538
  cluster request failed: Unknown error 65538
  VG         #PV #LV #SN Attr   VSize  VFree
  vg_qemu01    1   9   0 wz--nc 52.12G 13.07G
  vg_virtfed   1   2   0 wz--n- 16.00G     0
  Internal error: Volume Group vg_qemu01 was not unlocked
  Internal error: Volume Group vg_virtfed was not unlocked
  Device '/dev/drbd0' has been left open.
  Device '/dev/block/104:2' has been left open.
  Device '/dev/drbd0' has been left open.
  Device '/dev/block/104:2' has been left open.
  Device '/dev/block/104:2' has been left open.
  Device '/dev/drbd0' has been left open.
  Device '/dev/block/104:2' has been left open.

so it seems that the cluster attribute is correctly present only for vg_qemu01
It seems that I can do normal operations such as adding an LV and so
on, but I don't understand the errors about
 Internal error: Volume Group vg_qemu01 was not unlocked
and
 Device '/dev/drbd0' has been left open.

Any clues?

dumpconfig from lvm> prompt gives:
  devices {
  	dir="/dev"
  	scan="/dev"
  	preferred_names=[]
  	filter=["a|^/dev/cciss/c0d0p2$|", "a|drbd.*|", "r|.*|"]
  	cache_dir="/etc/lvm/cache"
  	cache_file_prefix=""
  	write_cache_state=1
  	sysfs_scan=1
  	md_component_detection=1
  	md_chunk_alignment=1
  	data_alignment=0
  	ignore_suspended_devices=0
  }
  activation {
  	missing_stripe_filler="error"
  	reserved_stack=256
  	reserved_memory=8192
  	process_priority=-18
  	mirror_region_size=512
  	readahead="auto"
  	mirror_log_fault_policy="allocate"
  	mirror_device_fault_policy="remove"
  }
  global {
  	umask=63
  	test=0
  	units="h"
  	activation=1
  	proc="/proc"
  	locking_type=3
  	fallback_to_clustered_locking=1
  	fallback_to_local_locking=1
  	locking_dir="/var/lock/lvm"
  }
  shell {
  	history_size=100
  }
  backup {
  	backup=1
  	backup_dir="/etc/lvm/backup"
  	archive=1
  	archive_dir="/etc/lvm/archive"
  	retain_min=10
  	retain_days=30
  }
  log {
  	verbose=0
  	syslog=1
  	file="/var/log/lvm2.log"
  	overwrite=0
  	level=6
  	indent=1
  	command_names=0
  	prefix="  "
  }

I set log verbosse (level 6) and when I run vgs command i get inside
the file /var/log/lvm2.log:

config/config.c:955   log/activation not found in config: defaulting to 0
commands/toolcontext.c:189   Logging initialised at Wed Jul 22 15:58:19 2009
config/config.c:950   Setting global/umask to 63
commands/toolcontext.c:210   Set umask to 0077
config/config.c:927   Setting devices/dir to /dev
config/config.c:927   Setting global/proc to /proc
config/config.c:950   Setting global/activation to 1
config/config.c:955   global/suffix not found in config: defaulting to 1
config/config.c:927   Setting global/units to h
config/config.c:927   Setting activation/readahead to auto
config/config.c:927   Setting activation/missing_stripe_filler to error
device/dev-cache.c:485   devices/preferred_names not found in config
file: using built-in preferences
config/config.c:950   Setting devices/ignore_suspended_devices to 0
config/config.c:927   Setting devices/cache_dir to /etc/lvm/cache
config/config.c:950   Setting devices/write_cache_state to 1
filters/filter-persistent.c:131   Loaded persistent filter cache from
/etc/lvm/cache/.cache
config/config.c:950   Setting activation/reserved_stack to 256
config/config.c:950   Setting activation/reserved_memory to 8192
config/config.c:950   Setting activation/process_priority to -18
format1/format1.c:532   Initialised format: lvm1
format_pool/format_pool.c:333   Initialised format: pool
format_text/format-text.c:2015   Initialised format: lvm2
config/config.c:933   global/format not found in config: defaulting to lvm2
striped/striped.c:228   Initialised segtype: striped
zero/zero.c:110   Initialised segtype: zero
error/errseg.c:113   Initialised segtype: error
freeseg/freeseg.c:57   Initialised segtype: free
snapshot/snapshot.c:312   Initialised segtype: snapshot
mirror/mirrored.c:579   Initialised segtype: mirror
config/config.c:950   Setting backup/retain_days to 30
config/config.c:950   Setting backup/retain_min to 10
config/config.c:927   Setting backup/archive_dir to /etc/lvm/archive
config/config.c:927   Setting backup/backup_dir to /etc/lvm/backup
config/config.c:955   global/fallback_to_lvm1 not found in config:
defaulting to 1
config/config.c:950   Setting global/locking_type to 3
locking/locking.c:253   Cluster locking selected.
config/config.c:955   report/aligned not found in config: defaulting to 1
config/config.c:955   report/buffered not found in config: defaulting to 1
config/config.c:955   report/headings not found in config: defaulting to 1
config/config.c:933   report/separator not found in config: defaulting to
config/config.c:955   report/prefixes not found in config: defaulting to 0
config/config.c:955   report/quoted not found in config: defaulting to 1
config/config.c:955   report/columns_as_rows not found in config:
defaulting to 0
config/config.c:933   report/vgs_sort not found in config: defaulting to vg_name
config/config.c:933   report/vgs_cols not found in config: defaulting
to vg_name,pv_count,lv_count,snap_count,vg_attr,vg_size,vg_free
toollib.c:572   Finding all volume groups
label/label.c:160   /dev/drbd0: lvm2 label detected
label/label.c:160   /dev/block/104:2: lvm2 label detected
label/label.c:184   /dev/dm-10: No label detected
locking/cluster_locking.c:458   Locking VG V_vg_virtfed CR B (0x1)
toollib.c:468   Finding volume group "vg_virtfed"
label/label.c:160   /dev/block/104:2: lvm2 label detected
config/config.c:933   description not found in config: defaulting to
config/config.c:927   Setting description to Created *after* executing
'lvextend -l +100%FREE /dev/vg_virtfed/lv_root'
locking/cluster_locking.c:458   Locking VG V_vg_virtfed UN B (0x6)
locking/cluster_locking.c:159   cluster request failed: Unknown error 65538
locking/cluster_locking.c:458   Locking VG V_vg_qemu01 CR B (0x1)
toollib.c:468   Finding volume group "vg_qemu01"
label/label.c:160   /dev/drbd0: lvm2 label detected
config/config.c:933   description not found in config: defaulting to
config/config.c:927   Setting description to Created *after* executing
'/sbin/lvcreate --name test_vm_drbd -L 4194304K /dev/vg_qemu01'
locking/cluster_locking.c:458   Locking VG V_vg_qemu01 UN B (0x6)
locking/cluster_locking.c:159   cluster request failed: Unknown error 65538
libdm-report.c:805   VG         #PV #LV #SN Attr   VSize  VFree
libdm-report.c:1065   vg_qemu01    1   9   0 wz--nc 52.12G 13.07G
libdm-report.c:1065   vg_virtfed   1   2   0 wz--n- 16.00G     0
filters/filter-persistent.c:199   Dumping persistent device cache to
/etc/lvm/cache/.cache
misc/lvm-file.c:236   Locking /etc/lvm/cache/.cache (F_WRLCK, 1)
misc/lvm-file.c:265   Unlocking fd 5
cache/lvmcache.c:1241   Wiping internal VG cache
cache/lvmcache.c:1235   Internal error: Volume Group vg_qemu01 was not unlocked
cache/lvmcache.c:1235   Internal error: Volume Group vg_virtfed was not unlocked
device/dev-cache.c:564   Device '/dev/drbd0' has been left open.
device/dev-cache.c:564   Device '/dev/block/104:2' has been left open.
device/dev-cache.c:564   Device '/dev/drbd0' has been left open.
device/dev-cache.c:564   Device '/dev/block/104:2' has been left open.
device/dev-cache.c:564   Device '/dev/block/104:2' has been left open.
device/dev-cache.c:564   Device '/dev/drbd0' has been left open.
device/dev-cache.c:564   Device '/dev/block/104:2' has been left open.


Thanks,
Gianluca


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]