[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] fencing error?



This is my cluster.conf.

<cluster alias="micluster" config_version="74" name="micluster">
    <fence_daemon post_fail_delay="5" post_join_delay="3"/>
    <clusternodes>
        <clusternode name="nodo1" nodeid="1" votes="1">
            <fence>
                <method name="1">
                    <device name="ILO-nodo1"/>
                </method>
            </fence>
        </clusternode>
        <clusternode name="nodo2" nodeid="2" votes="1">
            <fence>
                <method name="1">
                    <device name="ILO-nodo2"/>
                </method>
            </fence>
        </clusternode>
    </clusternodes>
    <cman expected_votes="1" two_node="1"/>
    <fencedevices>
        <fencedevice agent="fence_ilo" hostname="ILO-nodo1" login="administrador" name="ILO-nodo1" passwd="pass"/>
        <fencedevice agent="fence_ilo" hostname="ILO-nodo2" login="administrador" name="ILO-nodo2" passwd="pass"/>
    </fencedevices>
    <rm>
        <failoverdomains>
            <failoverdomain name="clusterfail" ordered="0" restricted="0">
                <failoverdomainnode name="nodo1" priority="1"/>
                <failoverdomainnode name="nodo1" priority="1"/>
            </failoverdomain>
        </failoverdomains>
        <resources>
            <ip address="172.31.120.11" monitor_link="1"/>
        </resources>
        <service autostart="1" domain="clusterfail" name="micluster" recovery="relocate">
            <ip ref="172.31.120.11"/>
        </service>
    </rm>
</cluster>

I started node1 and everything is ok, i started node2 and when is cheking the fencing node2 restarts node1.
I can't understand why.

thank you

2009/3/17 Nehemias Jahcob <nehemiasjahcob gmail com>
Tu problema es que estas cruzando la ILO, cada ILO debe ser el fence de cada maquina..

Algo asi.

Cluster.conf..
########################################################################
<?xml version="1.0"?>
<cluster alias="ExampleCLST" config_version="2" name="EXM">
        <fence_daemon post_fail_delay="10" post_join_delay="15"/>
        <clusternodes>
                <clusternode name="node1" nodeid="1" votes="1">
                        <fence>
                                <method name="1">
                                        <device name="node1_ilo"/>
                                </method>
                        </fence>
                </clusternode>
                <clusternode name="node2" nodeid="2" votes="1">
                        <fence>
                                <method name="1">
                                        <device name="node2_ilo"/>
                                </method>
                        </fence>
                </clusternode>
        </clusternodes>
        <cman expected_votes="1" two_node="1"/>
        <fencedevices>
                <fencedevice agent="fence_ilo" hostname="192.168.1.80" login="rhcs" name="node1_ilo" passwd="rhcs_example"/>
                <fencedevice agent="fence_ilo" hostname="192.168.1.81" login="rhcs" name="node2_ilo" passwd="rhcs_example"/>
        </fencedevices>
        <rm>
                <failoverdomains>
                        <failoverdomain name="interactivo-2" ordered="0" restricted="0">
                                <failoverdomainnode name="node1" priority="1"/>
                                <failoverdomainnode name="node2" priority="1"/>
                        </failoverdomain>
                </failoverdomains>
                <resources>
                        <ip address="192.168.1.85" monitor_link="1"/>
                        <ip address="192.168.1.86" monitor_link="1"/>
                </resources>
                <service autostart="1" name="Apache" recovery="restart">
                        <script file="/etc/init.d/httpd" name="Apache"/>
                        <script file="/etc/init.d/mysqld" name="Mysql"/>
                        <ip ref="192.168.1.85"/>
                </service>
                <service autostart="1" name="FTP" recovery="restart">
                        <script file="/etc/init.d/vsftpd" name="FTP">
                                <ip ref="192.168.1.86"/>
                        </script>
                </service>
        </rm>
</cluster>
##########################################################################


Saludos.

--
Linux-cluster mailing list
Linux-cluster redhat com
https://www.redhat.com/mailman/listinfo/linux-cluster


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]