[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] Openais doesn't sync, coninuos errors



carlopmart wrote:
> Hi all,
> 
>  I have a strange problem with a CentOS5 cluster (two nodes). Under
> /var/log/messages I see this errors:
> 
> May 21 23:46:51 radagast openais[6283]: [MAIN ] Received message has
> invalid digest... ignoring.
> May 21 23:46:51 radagast openais[6283]: [MAIN ] Invalid packet data
> May 21 23:46:51 radagast openais[6283]: [MAIN ] Received message has
> invalid digest... ignoring.
> May 21 23:46:51 radagast openais[6283]: [MAIN ] Invalid packet data
> May 21 23:46:51 radagast openais[6283]: [MAIN ] Received message has
> invalid digest... ignoring.
> May 21 23:46:51 radagast openais[6283]: [MAIN ] Invalid packet data
> May 21 23:46:52 radagast openais[6283]: [MAIN ] Received message has
> invalid digest... ignoring.
> May 21 23:46:52 radagast openais[6283]: [MAIN ] Invalid packet data
> May 21 23:46:52 radagast openais[6283]: [MAIN ] Received message has
> invalid digest... ignoring.
> May 21 23:46:52 radagast openais[6283]: [MAIN ] Invalid packet data
> May 21 23:46:53 radagast openais[6283]: [MAIN ] Received message has
> invalid digest... ignoring.
> May 21 23:46:53 radagast openais[6283]: [MAIN ] Invalid packet data
> May 21 23:46:53 radagast openais[6283]: [MAIN ] Received message has
> invalid digest... ignoring.
> May 21 23:46:53 radagast openais[6283]: [MAIN ] Invalid packet data
> May 21 23:46:53 radagast openais[6283]: [MAIN ] Received message has
> invalid digest... ignoring.
> May 21 23:46:53 radagast openais[6283]: [MAIN ] Invalid packet data
> May 21 23:46:54 radagast openais[6283]: [MAIN ] Received message has
> invalid digest... ignoring.
> May 21 23:46:54 radagast openais[6283]: [MAIN ] Invalid packet data
> May 21 23:46:54 radagast openais[6283]: [MAIN ] Received message has
> invalid digest... ignoring.
> May 21 23:46:54 radagast openais[6283]: [MAIN ] Invalid packet data
> May 21 23:46:54 radagast openais[6283]: [MAIN ] Received message has
> invalid digest... ignoring.
> May 21 23:46:54 radagast openais[6283]: [MAIN ] Invalid packet data
> May 21 23:46:55 radagast openais[6283]: [MAIN ] Received message has
> invalid digest... ignoring.
> May 21 23:46:55 radagast openais[6283]: [MAIN ] Invalid packet data
> May 21 23:46:55 radagast openais[6283]: [MAIN ] Received message has
> invalid digest... ignoring.
> May 21 23:46:55 radagast openais[6283]: [MAIN ] Invalid packet data
> May 21 23:46:56 radagast openais[6283]: [MAIN ] Received message has
> invalid digest... ignoring.
> May 21 23:46:56 radagast openais[6283]: [MAIN ] Invalid packet data
> 
>  .. and rgmanager doesn't starts different services that I configured.
> Can this be a network problem?? Why can't I start services configured
> under cluster.conf ?? I see the same errors on the other node. Both
> nodes are centos5.3, kernel 2.6.18-128.1.10.el5, and cman
> cman-2.0.98-1.el5_3.1.


Nothing will work until those errors are gone. They mean that the
openais processes on the two nodes are not talking to each other.

There are a few things to check. Firstly manse sure that openais is
being run from cman and not on its own ('chkconfig openais off'). Also
check that cluster.conf is the same on both nodes, in particular the
cluster names match and if there is a cluster_id specified that it's the
same on both nodes too.

it's also worth checking for iptables rules that might be fiddling with
the packets.

Failing that, you might just have the most dreadful network corruption I
have ever seen ...


Chrissie


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]