[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Linux-cluster] haproxy terminate connection


I am running haproxy -, with the following *simple* configuration:

        log   local0
        log   local1 notice
        #log loghost    local0 info
        maxconn 4096
        #chroot /usr/share/haproxy
        #uid 99
        #gid 99
        pidfile /var/run/haproxy.pid

        log     global
        mode    http
        option  httplog
        option  dontlognull
        retries 3
        option redispatch
        maxconn 2000
        contimeout      5000
        clitimeout      50000
        srvtimeout      50000

listen web_appl
        mode http
        cookie SERVERID insert nocache indirect
        balance roundrobin
        server wp1 cookie server01 weight 1 check
        server wp2 cookie server02 weight 1 check
        server wp3 cookie server03 weight 1 check
        server wp4-backup cookie server04 check backup
        server wp5-backup check backup
        option abortonclose # Dropping aborted requests
        option nolinger # disables data lingering is the address of the haproxy load balancer.
When I tried lynx within the haproxy server
(, it works, it directed me to, because
all other servers have no httpd running.
When I tried from my vista windows, it said
"Connection Interrupted".

What is the problem with my setup?

Your suggestion is very much appreciated.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]