[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Linux-cluster] clustat failed state



Hi,
 
I have tried to setup a simple http cluster setup but when I reboot a node manually cluster service state goes to failed and manual intervention required.
Can someone enligthen me what is wrong with the following config. If I fence one one service are taken over by the other node but not with reboot
 
 
 Here is my config :
 
<?xml version="1.0"?>
<cluster alias="test" config_version="17" name="test">
        <fence_daemon clean_start="0" post_fail_delay="0" post_join_delay="3"/>
        <clusternodes>
                <clusternode name="node2.test.com" nodeid="1" votes="1">
                        <fence>
                                <method name="1">
                                        <device name="vmware-fence-node2" port="/vmfs/volumes/4996b593-80041c90-393f-0015174e5fb1/RHCS_Test2/RHCS_Test2.vmx" secure="1"/>
                                </method>
                        </fence>
                </clusternode>
                <clusternode name="node1.test.com" nodeid="2" votes="1">
                        <fence>
                                <method name="1">
                                        <device name="vmware-fence-node1" port="/vmfs/volumes/4996b593-80041c90-393f-0015174e5fb1/RHCS_Test1/RHCS_Test1.vmx" secure="1"/>
                                </method>
                        </fence>
                </clusternode>
        </clusternodes>
        <cman expected_votes="1" two_node="1"/>
        <fencedevices>
                <fencedevice agent="fence_vmware" ipaddr="10.0.0.105" login="test" name="vmware-fence-node2" passwd="test" vmlogin="root" vmpasswd="test"/>
                <fencedevice agent="fence_vmware" ipaddr="10.0.0.105" login="test" name="vmware-fence-node1" passwd="test" vmlogin="root" vmpasswd="test"/>
        </fencedevices>
        <rm>
                <failoverdomains>
                        <failoverdomain name="httpd_failover" nofailback="0" ordered="0" restricted="1">
                                <failoverdomainnode name="node2.test.com" priority="1"/>
                                <failoverdomainnode name="node1.test.com" priority="1"/>
                        </failoverdomain>
                </failoverdomains>
                <resources/>
                <service autostart="1" domain="httpd_failover" exclusive="0" max_restarts="0" name="httpd" recovery="restart" restart_expire_time="0">
                        <ip address="10.0.0.100" monitor_link="1">
                                <apache config_file="conf/httpd.conf" name="apache_service" server_root="/etc/httpd" shutdown_wait="0"/>
                        </ip>
                </service>
        </rm>
</cluster>
 
 

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]