[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] gfs2 quotas



Hi Scooter,

The 'gfs2_quota reset' command should truncate the hidden quota file down to just root uid/gid quotas and these warnings should cease. Seems like that's not happening for you. I'd like to take a look at the hidden quota file (if possible, the filesystem itself) to see what's going on. Please open a RH bugzilla for this problem.

If the filesystem is not too big and you can share it, please compress+upload it someplace and send me the link to it. If you can't share the filesystem, I'd like to atleast look at the hidden quota file. Please do the following to retrieve that. I must warn you that this *might* hang/crash the filesystem, and you might have to restart your machine.
1. Mount the gfs2 filesystem (say at /mnt/gfs2)
2. Mount the gfs2meta filesystem - mount -t gfs2meta /mnt/gfs2 /tmp/.gfs2meta
3. ls -l /tmp/.gfs2meta/quota
Check that the above file is not unreasonably large (there used to be a known issue where this file could get huge (100s of GB). It doesn't actually use all that space as it's a sparse file. I believe this was fixed at one point, I just don't know if you have the fix or not)
4. If the above file is small, just do 'cp /tmp/.gfs2meta/ /tmp/foo'
5. umount /tmp/.gfs2meta && umount /mnt/gfs2

Please compress and email me foo.

Thanks!
--Abhi

----- Original Message -----
From: "Scooter Morris" <scooter cgl ucsf edu>
To: "linux clustering" <linux-cluster redhat com>
Sent: Friday, October 9, 2009 4:35:26 PM GMT -06:00 US/Canada Central
Subject: [Linux-cluster] gfs2 quotas

Hi all,
    I'm trying to set up quotas on my gfs2 filesystems, and I'm running 
into some problems.  I enabled quotas (quota=on), did a gfs2_quota reset 
and a gfs2_quota init.  Now, I'm getting warning messages:

warning: quota file size not a multiple of struct gfs2_quota

and

Warning: This filesystem doesn't seem to have the new quota list format 
or the quota list is corrupt. list, check and init operation performance 
will suffer due to this. It is recommended that you run the 'gfs2_quota 
reset' operation to reset the quota file. All current quota information 
will be lost and you will have to reassign all quota limits and warnings

I've tried doing a reset/init/check, fsck.gfs2, etc., but I still get 
the same warnings.   Am I doing something wrong?

RHEL 5.4:
    Linux 2.6.18-164.el5
    gfs2-utils-0.1.62-1.el5

-- scooter



--
Linux-cluster mailing list
Linux-cluster redhat com
https://www.redhat.com/mailman/listinfo/linux-cluster


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]