[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Linux-cluster] Virsh instead of XM?



Hi!

I have a trouble using Virsh instead of xm in RHEL 5.4... I get these
logs when trying to enable virtual machine:

Oct 15 23:30:35 lego02 clurgmgrd[16072]: <notice> start on vm
"my.vm1" returned 1 (generic error)
Oct 15 23:30:35 lego02 clurgmgrd[16072]: <notice> start on vm
"my.vm2" returned 1 (generic error)

I would like to migrate from xm to virsh, though...

I see in /usr/share/cluster scripts there are some words on debug
logging, but I don't know how to turn it on? I would like to see what
is the virsh command that cluster tries to use, because when I try to
start virtual machine by virsh manually, everything works.

Here is a snippet from cluster.conf:

<vm name="my.vm1" hypervisor="xen" autostart="1"
use_virsh="1" domain="mydomain" migrate="live" recovery="relocate"
path="/etc/xen/domains"
migration_mapping="lego01:lego01-bond1,lego02:lego02-bond1,lego03:lego03-bond1"/>


Should I change anything?

My config files are in /etc/xen/domains, and they are written for xm,
but even if I change them to virsh XML's, it still doesn't work...






-- 
|    Jakov Sosic    |    ICQ: 28410271    |   PGP: 0x965CAE2D   |
=================================================================
| start fighting cancer -> http://www.worldcommunitygrid.org/   |


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]