[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] Virsh instead of XM?



On Thu, 15 Oct 2009 23:48:40 +0200
Jakov Sosic <jakov sosic srce hr> wrote:

> <vm name="my.vm1" hypervisor="xen" autostart="1"
> use_virsh="1" domain="mydomain" migrate="live" recovery="relocate"
> path="/etc/xen/domains"
> migration_mapping="lego01:lego01-bond1,lego02:lego02-bond1,lego03:lego03-bond1"/>

So, what should I do to make it start?! I've changed the cluster.conf
line to:

<vm name="my.vm1" hypervisor="xen" autostart="1"
use_virsh="1" domain="mydomain" migrate="live" recovery="relocate"
xmlfile="/etc/xen/my.vm1.xml"
migration_mapping="lego01:lego01-bond1,lego02:lego02-bond1,lego03:lego03-bond1"/>

and then I've found the line that vm.sh is calling upon "clusvcadm -e
vm:my.vm1", and here it is:

[root lego01 cluster]# virsh -c xen:/// start my.vm1
libvir: error : configuration file syntax error: expecting a name
libvir: error : configuration file syntax error: expecting a name
libvir: error : configuration file syntax error: expecting an assignment
libvir: Xen error : Domain not found: xenUnifiedDomainLookupByName
error: failed to get domain 'my.vm1'





-- 
|    Jakov Sosic    |    ICQ: 28410271    |   PGP: 0x965CAE2D   |
=================================================================
| start fighting cancer -> http://www.worldcommunitygrid.org/   |


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]