[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] Virsh instead of XM?



On Thu, 2009-10-15 at 23:48 +0200, Jakov Sosic wrote:
> Hi!
> 
> I have a trouble using Virsh instead of xm in RHEL 5.4... I get these
> logs when trying to enable virtual machine:
> 
> Oct 15 23:30:35 lego02 clurgmgrd[16072]: <notice> start on vm
> "my.vm1" returned 1 (generic error)
> Oct 15 23:30:35 lego02 clurgmgrd[16072]: <notice> start on vm
> "my.vm2" returned 1 (generic error)
> 
> I would like to migrate from xm to virsh, though...
> 
> I see in /usr/share/cluster scripts there are some words on debug
> logging, but I don't know how to turn it on? I would like to see what
> is the virsh command that cluster tries to use, because when I try to
> start virtual machine by virsh manually, everything works.
> 
> Here is a snippet from cluster.conf:
> 
> <vm name="my.vm1" hypervisor="xen" autostart="1"
> use_virsh="1" domain="mydomain" migrate="live" recovery="relocate"
> path="/etc/xen/domains"
> migration_mapping="lego01:lego01-bond1,lego02:lego02-bond1,lego03:lego03-bond1"/>
> 
> 
> Should I change anything?

Put your domains in /etc/xen and remove the path attribute.  'virsh'
does not have a way to specify alternative search paths, consequently,
using 'path' requires use of 'xm'.

Federico's 'xmlfile' patch allows vm.sh to take a name + a full path to
a libvirt .xml file for using virsh, but it's not in RHEL.

-- Lon


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]