[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] OT? Odd Xen network issue



Madison Kelly wrote:
Hi all,

I hope this isn't too off-topic being more a Xen than cluster experience, but I am having trouble with the Xen mailing list and I gather many here use Xen. If it is too off-topic, the please have a mod delete it and kick my butt. :)

I've got a simple two-node cluster, each with three NICs running CentOS 5.3 x86_64. Each node has this configuration:

eth0 - Internal network and VM back channel (IPMI on this NIC)
eth1 - DRBD link
eth2 - Internet-facing NIC, dom0 has no IP

I've built a simple VM that uses 'xenbr0' and 'xenbr2' as the VM's 'eth0' and 'eth1', respectively. I've set a static, public IP to domU's eth1 (xenbr2) but I can't ping it from a workstation nor can the domU ping out. I know that the network itself (outside the server) is setup right as I tested the static IP from that cable earlier on a test machine.

Could someone hit me with a clue-stick as to what I might be doing wrong? Let me know if any logs or config files are helpful.

First, see if you can ping dom0's NICs? If not, that's the first thing to address.

Next, are the domUs NICs up? ("ifconfig -a" will tell you).  If not,
bring them up.  Remember, you might have a fight if the domUs use
Gnome's NetworkManager.  Make sure it's disabled and that you have the
classic configuration set up in the domUs correctly.

Verify that first, and we'll move on from there.  You might also want
to have a look at this:

	http://wiki.xensource.com/xenwiki/XenNetworking

It might help explain things a bit or give you some other ideas.
----------------------------------------------------------------------
- Rick Stevens, Systems Engineer                      ricks nerd com -
- AIM/Skype: therps2        ICQ: 22643734            Yahoo: origrps2 -
-                                                                    -
-     Have you noticed that "human readable" configuration file      -
-          directives are beginning to resemble COBOL code?          -
----------------------------------------------------------------------


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]