[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] 3 node cluster and quorum disk?



On Wed, Aug 26, 2009 at 9:11 AM, Jakov Sosic<jakov sosic srce hr> wrote:
> Hi.
>
> I have a situation - when two nodes are up in 3 node cluster, and one
> node goes down, cluster looses quorate - although I'm using qdiskd...
>
> I think that problem is in switching qdisk master from one node to
> another. In that case, rgmanager disables all running services, which is
> not acceptable situation. Services are currently set to
> autostart="0" because cluster is in evaluation phase.
>
> Here is my config:
>
> <?xml version="1.0"?>
> <cluster alias="cluster-c00" config_version="56" name="cluster-c00">
>        <fence_daemon post_fail_delay="0" post_join_delay="120"/>
>        <!-- DEFINE CLUSTER NODES, AND FENCE DEVICES  -->
>        <clusternodes>
>                <clusternode name="node01" nodeid="1" votes="1">
>                        <fence>
>                                <method name="1">
>                                        <device name="node01-ipmi"/>
>                                </method>
>                        </fence>
>                </clusternode>
>                <clusternode name="node02" nodeid="2" votes="1">
>                        <fence>
>                                <method name="1">
>                                        <device name="node02-ipmi"/>
>                                </method>
>                        </fence>
>                </clusternode>
>                <clusternode name="node03" nodeid="3" votes="1">
>                        <fence>
>                                <method name="1">
>                                        <device name="node03-ipmi"/>
>                                </method>
>                        </fence>
>                </clusternode>
>        </clusternodes>
>
>        <!-- DEFINE CLUSTER MANAGER BEHAVIOUR -->
>        <cman expected_votes="3" deadnode_timeout="80"/>
> <!--            <multicast addr="224.0.0.1"/>   </cman> -->
>
>        <!-- Token -->
>        <totem token="55000"/>
>
>        <!-- Quorum Disk -->
>        <quorumd interval="5" tko="5" votes="2"
>        label="SAS-qdisk" status_file="/tmp/qdisk"/>
>
>        <!-- DEFINE FENCE DEVICES -->
>        <fencedevices>
>                <fencedevice agent="fence_ipmilan" auth="password"
>        ipaddr="" login="" passwd="" name="node01-ipmi"/>
>                <fencedevice agent="fence_ipmilan" auth="password"
>        ipaddr="" login="" passwd="" name="node02-ipmi"/>
>                <fencedevice agent="fence_ipmilan" auth="password"
>        ipaddr="" login="" passwd="" name="node03-ipmi"/>
>        </fencedevices>
>
> </cluster>
>
> Should I change any of the timeouts?
>
>
>
>
>
>
> --
> |    Jakov Sosic    |    ICQ: 28410271    |   PGP: 0x965CAE2D   |
> =================================================================
> | start fighting cancer -> http://www.worldcommunitygrid.org/   |
>
> --
> Linux-cluster mailing list
> Linux-cluster redhat com
> https://www.redhat.com/mailman/listinfo/linux-cluster
>

I ran into the same problem. I am also running a 3 nodes cluster with
qdisk. Before, my node1 , node2  and nod3 has 1, 1, 2 votes and qdisk
had 2. I ran into the same problem as u are having now. Then I change
the votes from 2 to 1 to node 3 and added a vote to qdisk . Now it is
running fine. I don't know what happed before. I have tested a lot but
didnot succeeded.

Now my,
interval = 1 and tko=10 in my case.

Paras.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]