[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] Trouble setting up a new cluster



On 08/27/2010 08:46 AM, Jason_Henderson Mitel com wrote:
> linux-cluster-bounces redhat com wrote on 08/27/2010 11:28:27 AM:
> 
>> I'm trying unsuccessfully to set up a new cluster on redhat 5.  The
>> nodes seem to see each other, but they alway start up inquorate and
>> never join up.  I'm not sure what else I should be looking at.  Iptables
>> is not running.
>>
>> [root uaz-so-w52 ~]# group_tool
>> type             level name       id       state
>> fence            0     default    00010001 none
>> [1]
>> dlm              1     clvmd      00020001 none
>> [1]
>> dlm              1     rgmanager  00030001 none
>> [1]
>>
>> [root uaz-so-w51 ~]# group_tool
>> type             level name  id       state
>>
>> [root uaz-so-w51 ~]# cman_tool nodes
>> Node  Sts   Inc   Joined               Name
>>    0   X      0                        /dev/mapper/soap1
>>    1   X      0                        uaz-so-w52.mosaic.arizona.edu
>>    2   M   7920   2010-08-26 10:04:51  uaz-so-w51.mosaic.arizona.edu
>>
>> [root uaz-so-w52 ~]# cman_tool nodes
>> Node  Sts   Inc   Joined               Name
>>    0   M      0   2010-08-26 09:59:16  /dev/mapper/soap1
>>    1   M   7436   2010-08-26 09:59:04  uaz-so-w52.mosaic.arizona.edu
>>    2   X      0                        uaz-so-w51.mosaic.arizona.edu
>>
>> Any help would be greatly appreciated.
> 
> Looks like they are each a member of their own cluster. Perhaps multicast 
> communication between the two nodes is not working. Are you using RedHat 
> 5.5?
> 
Yes, it's rh 5.5.  And multicast not working is the track I've been
running down.  Our network team tells me multicast is enabled within the
switch.  I had used ssmping to test multicast and it seemed to be
working.  I just ran it (ssmping) again, and if I start ssmpingd on node
1 and run ssmping from node 2 it works fine.  If I start ssmpingd from
node 2 and run ssmping from node 1 I get connection refused errors from
ssmping.

Thanks,
Todd


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]