[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Linux-cluster] rgmanager gets stuck on shutdown, if no services are running on its node.



Hi,
 
I configured a cluster of 2 RHEL6 nodes. 
The cluster has only one HA service defined.
 
I have a problem with rgmanager getting stuck on shutdown when certain set of conditions are met.  The details follow.
 
1.
If I execute “shutdown –h now” on the node that is *not* running the HA service then the shutdown process gets stuck with the last message in the /var/log/messages being:
 
‘date’ my_node_name  rgmanager[PID#]: Shutting down
 
The shutdown never completes, until I send terminate signal to the two instances of the rgmanager process. Then shutdown completes normally.
 
2.
By comparison, if I execute “shutdown –h now” on a node that *is* running the HA service, then shutdown proceeds normally.
 
3.
The problem walks with the absence of the service i.e. each of the two nodes has the problem when the service is *not* running on it and does not have the problem when the service *is* running on it.
 
4.
I have set the following debug level in the cluster.conf:
 
<logging>
        <logging_daemon debug=”on” name=”rgmanager”/>
</logging>
 
But I am not getting any additional messages when the rgmanager is stuck during shutdown.
 
Questions:
Is this a known problem?
How can I avoid it short of having some dummy service running on each node, as a workaround?
 
Thanks and regards,
 
Chris Jankowski
 
 
 
 

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]