[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Linux-cluster] CLVM and snapshot: test results and questions



Hi all,

according to RedHat's docs creating snapshots in a cluster environment should be basically possible.
Here is what the "Cluster_Logical_Volume_Manager.pdf" says on page 49:
LVM snapshots are not cluster-aware, so they require exclusive access to a volume. For information on activating logical volumes on individual nodes in a cluster, see Section 8, “Activating
Logical Volumes on Individual Nodes in a Cluster”.
In Section 8 they write
To activate logical volumes exclusively on one node, use the lvchange -aey command.
I have a 2 node cluster using GFS shared volumes based on CLVM. According to the above I tried the following:

- umount a GFS volume on node 2
- gfs_tool freeze /mountpoint/of/GFSvolume
- lvchange -aey LOGICALVOLUMEgfsresideson on node 1

I got an "error locking ..." then.

Next I tried "lvchange -an LOGICALVOLUME..." on node 2 which threw the same error, but after a while "lvchange -aey LOGICALVOLUMEgfsresideson" on node 1 worked and the logical volume did not appear on node 2 with "lvdisplay".

So now I tried "lvcreate ... -s ..." on node 1 to create a snapshot, but received the standard error that shapshots of clustered volumes are not implemented yet.

Now there is 2 possibilities how this could be understood:
1. lvcreate refuses snapshotting cluster logical volumes if the cluster bit is there - disregarding the exclusivity of the activation state.
2. I did something wrong or incomplete.

I really would regret number 1 being true, and because of the errors I received inbetween I hope that 2 comes up as winner. :-) E.g. on HPUX you have to activate the volume group exclusively, not the logical volume. Could that be the reason.

Is anyone out there who can shed enough light on all this?

Thanks for any hint or help

Dirk


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]