[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Linux-cluster] redhat apache cluster probelm





Hi,

Using RHEL 5.3 and HP-ILo as fencing device. i did the following for testing Apache-Cluster.

1. root#mkqdisk -c /dev/sda1 -l DB_Q
2. root#chkconfig --level 345 qdiskd on
3. root#service qdiskd start
4. root#system-config-cluster

5. Cluster Name : jkz and selected quorum disk with following options
Interval = 1
TKO = 10
votes = 1
Minimum score = 3
Device = /dev/sda1
Label = DB_Q

6. Quorum Disk Heuristic
Program = ping -c 2 10.10.10.1
Score = 1
Interval = 2

7. Add new node to cluster
Node Name = node1.example.com
Quorum votes = 1
Node Name = node2.example.com
Quorum votes = 1

8. New Fence Device
HP ILO Device
Name = ILOGB89xxxxxx
user = manage
password = manage
Hostname = 10.10.10.100


HP ILO Device
Name = ILOGB88xxxxxx
user = manage
password = manage
Hostname = 10.10.10.101


9. selected Node1 and "Manage fencing for this node"
Add New Fencing level -> Add Fencing to this Level. selected ILOGB89xxxxxx

10. selected Node2 and "Manage fencing for this node"
Add New Fencing level -> Add Fencing to this Level. selected ILOGB88xxxxxx


11. Created failover domains "failover-cluster" and selected "node1.example.com and node2.example.com" from menu, and selected "Restrict to this Failover Domain"


12. Create Resource
New Resource = Apache Server
Name = Apache HTTP Server service
Server Root = /etc/httpd
Config File = /etc/httpd/conf/httpd.conf
httpd options = /etc/rc.d/init.d/httpd


13. Create a new Resource "File system"

Name = httpd-content
File System type = ext3
Mount point = /var/www/html
device = /dev/sdb1

14. Create a new Resource "IP "

10.10.10.200


15. Create a New Service "Web-Service"
Failover Domain = failover-cluster

And selected "Add shared resource to this service"

A. Apache HTTP Server Service
B. Httpd-Content
C. IP Address (10.10.10.200)



After doing all this. when i start cman service, it hangs and error puts in /var/log/messages

root## service cman start
Starting cluster:
Loading modules... done
Mounting configfs... done
Starting ccsd... done
Starting cman... done
Starting qdiskd... done
Starting daemons... done
Starting fencing...


root#tail /var/log/messages

Jan 23 17:31:24 node1 ccsd[17103]: Cluster is not quorate. Refusing connection.
Jan 23 17:31:24 node1 ccsd[17103]: Error while processing connect: Connection refused
Jan 23 17:31:29 node1 ccsd[17103]: Cluster is not quorate. Refusing connection.
Jan 23 17:31:29 node1 ccsd[17103]: Error while processing connect: Connection refused
Jan 23 17:31:34 node1 ccsd[17103]: Cluster is not quorate. Refusing connection.
Jan 23 17:31:34 node1 ccsd[17103]: Error while processing connect: Connection refused
Jan 23 17:31:39 node1 ccsd[17103]: Cluster is not quorate. Refusing connection.
Jan 23 17:31:39 node1 ccsd[17103]: Error while processing connect: Connection refused


 
Thanks,
 Ammad Shah
 




Windows Live: Keep your friends up to date with what you do online.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]