[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] Adding third node to existing cluster problem



Title: Re: Adding third node to existing cluster problem

Hi

Yes I have done this way. When I try to start on third node cman start fails and cman_tool shows that it is not recognizing other two nodes which are working properly..

[root usrylxap235 ~]# service cman start
Starting cluster:
   Loading modules... done
   Mounting configfs... done
   Starting ccsd... done
   Starting cman... done
   Starting daemons... done
   Starting fencing...




failed

                                                           [FAILED]

[root usrylxap235 ~]# cman_tool status
Version: 6.1.0
Config Version: 44
Cluster Name: cluster1
Cluster Id: 26777
Cluster Member: Yes
Cluster Generation: 84
Membership state: Cluster-Member
Nodes: 1
Expected votes: 3
Total votes: 1
Quorum: 2 Activity blocked
Active subsystems: 5
Flags:
Ports Bound: 0
Node name: usrylxap235-1.merck.com
Node ID: 3
Multicast addresses: 239.192.104.2
Node addresses: 192.168.0.7


Attached is cluster.conf file.
<<clusterconfig.txt>>
Thanks
Anoop


Notice:  This e-mail message, together with any attachments, contains
information of Merck & Co., Inc. (One Merck Drive, Whitehouse Station,
New Jersey, USA 08889), and/or its affiliates Direct contact information
for affiliates is available at 
http://www.merck.com/contact/contacts.html) that may be confidential,
proprietary copyrighted and/or legally privileged. It is intended solely
for the use of the individual or entity named on this message. If you are
not the intended recipient, and have received this message in error,
please notify us immediately by reply e-mail and then delete it from 
your system.
[root usrylxap235 ~]# more /etc/cluster/cluster.conf
<?xml version="1.0"?>
<cluster alias="cluster1" config_version="44" name="cluster1">
        <fence_daemon clean_start="0" post_fail_delay="0" post_join_delay="100"/>
        <clusternodes>
                <clusternode name="usrylxap237-1.merck.com" nodeid="1" votes="1">
                        <fence>
                                <method name="1">
                                        <device name="usrylxap237r"/>
                                </method>
                        </fence>
                </clusternode>
                <clusternode name="usrylxap238-1.merck.com" nodeid="2" votes="1">
                        <fence>
                                <method name="1">
                                        <device name="usrylxap238r"/>
                                </method>
                        </fence>
                </clusternode>
                <clusternode name="usrylxap235-1.merck.com" nodeid="3" votes="1">
                        <fence>
                                <method name="1">
                                        <device name="usrylxap235r"/>
                                </method>
                        </fence>
                </clusternode>
        </clusternodes>
        <cman/>
        <fencedevices>
                <fencedevice agent="fence_ilo" hostname="usrylxap237r.merck.com" login="admin" name="usrylxap237r" pass
wd="xyz"/>
                <fencedevice agent="fence_ilo" hostname="usrylxap238r.merck.com" login="admin" name="usrylxap238r" pass
wd="xyz"/>
                <fencedevice agent="fence_ilo" hostname="usrylxap235r.merck.com" login="admin" name="usrylxap235r" pass
wd="xyz"/>
        </fencedevices>
        <rm>
                <failoverdomains>
                        <failoverdomain name="webdomain" nofailback="0" ordered="1" restricted="1">
                                <failoverdomainnode name="usrylxap237-1.merck.com" priority="1"/>
                                <failoverdomainnode name="usrylxap238-1.merck.com" priority="2"/>
                                <failoverdomainnode name="usrylxap235-1.merck.com" priority="3"/>
                        </failoverdomain>
                </failoverdomains>
                <resources>
                        <ip address="54.3.254.109" monitor_link="1"/>
                        <script file="/etc/init.d/orig.httpd" name="http startup script"/>
                        <fs device="/dev/sda2" force_fsck="0" force_unmount="0" fsid="6443" fstype="ext3" mountpoint="/
var/www/html" name="httpd-content" options="" self_fence="0"/>
                        <fs device="/dev/sda1" force_fsck="0" force_unmount="0" fsid="30579" fstype="ext3" mountpoint="
/var/lib/mysql" name="mysql-content" options="" self_fence="0"/>
                        <script file="/etc/init.d/mysqld" name="mysql startup script"/>
                        <ip address="192.168.0.3" monitor_link="1"/>
                </resources>
                <service autostart="1" domain="webdomain" name="http-service" recovery="restart">
                        <script ref="http startup script"/>
                        <fs ref="httpd-content"/>
                        <ip ref="54.3.254.109"/>
                </service>
                <service autostart="1" domain="webdomain" exclusive="0" name="mysql" recovery="disable">
                        <fs ref="mysql-content"/>
                        <script ref="mysql startup script"/>
                        <ip ref="192.168.0.3"/>
                </service>
        </rm>
</cluster>

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]