[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Linux-cluster] nfsclient: nfsclient1 is missing



Hi All, 

I´m configuring a cluster with a nfs sevice. I have followd this documentation:
http://www.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5/pdf/Configuration_Example_-_NFS_Over_GFS.pdf

now I have only one node but I can´t make it works, 

The nfs service starts but after few seconds I get this error:
Mar  2 18:32:11 server1 clurgmgrd: [25700]: <err> nfsclient:nfsclient1 is missing!
Mar  2 18:32:11 server1 clurgmgrd[25700]: <notice> status on nfsclient "nfsclient1" returned 1 (generic error)
Mar  2 18:32:21 server1 clurgmgrd[25700]: <notice> Stopping service service:nfssvc
Mar  2 18:32:21 server1 avahi-daemon[4075]: Withdrawing address record for 172.16.178.82 on eth0.
Mar  2 18:32:31 server1 clurgmgrd[25700]: <notice> Service service:nfssvc is recovering
Mar  2 18:32:31 server1 clurgmgrd[25700]: <notice> Service service:nfssvc is stopped

And the services stops, 

I suposse the problem is with the configuration of the nfsclient, but I don´t see the problem. The configuration is here:

<resources>
                        <ip address="172.16.178.82" monitor_link="0"/>
                        <clusterfs device="/dev/sdb1" force_unmount="0" fsid="45793" fstype="gfs2" mountpoint="/home/nfsdata/" name="nfsdata" options="rw"/>
                        <nfsexport name="nfsexport"/>
                        <nfsclient name="nfsclient1" options="rw" target="nfsclient1.dominio.es"/>
                </resources>
                <service autostart="1" domain="FAILDM name="nfssvc" recovery="relocate">
                        <ip ref="172.16.178.82"/>
                        <clusterfs ref="nfsdata">
                                <nfsexport ref="nfsexport">
                                        <nfsclient ref="nfsclient1"/>
                                </nfsexport>
                        </clusterfs>
                </service>


I have checked this link http://lists.centos.org/pipermail/centos/2008-January/049697.html but I don´t see the error, 

any idea?

Thanks in advance

ESG

 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]