[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Linux-cluster] Bug with /usr/share/system-config-cluster/misc/cluster.ng ?



I've got a fully up to date CentOS 5.4 x86_64 node that I've been trying to get to successfully validate my cluster.conf file on. However, nothing I do will succeed.

Out of frustration, I copy/pasted the example minimalist cluster.conf sample from the man page and even it fails to validate:

root an_san01:/etc/cluster# xmllint --relaxng /usr/share/system-config-cluster/misc/cluster.ng /etc/cluster/cluster.conf
<?xml version="1.0"?>
<cluster name="an_san" config_version="1">
	<clusternodes>
		<clusternode name="node-01" nodeid="1">
		</clusternode>
		<clusternode name="node-02" nodeid="2">
		</clusternode>
		<clusternode name="node-03" nodeid="3">
		</clusternode>
	</clusternodes>
</cluster>
/etc/cluster/cluster.conf:3: element clusternode: Relax-NG validity error : Invalid attribute nodeid for element clusternode /etc/cluster/cluster.conf:3: element clusternode: Relax-NG validity error : Element clusternodes has extra content: clusternode /etc/cluster/cluster.conf:1: element cluster: Relax-NG validity error : Invalid sequence in interleave /etc/cluster/cluster.conf:1: element cluster: Relax-NG validity error : Element cluster failed to validate content
/etc/cluster/cluster.conf fails to validate

  Is this a bug or am I being particularly daft?

--
Madison Kelly   647-501-5200
E-Mail:         mkelly alteeve com
AN!Whitepapers: http://alteeve.com
Node Assassin:  http://nodeassassin.org


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]