[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] Unable to start cman on FC12 VM's Cluster3



Hi,

Indeed, I tried configuring fence devices but no success.

Iptables are disabled, and even multicast was replaced by broadcat in
the cluster.conf with no success.

I can ping the 255.255.255.255 from each cluster node, and I can see
the traffic originated from both nodes when tcpdump'ing on host
255.255.255.255.

Fabio when you say put a breakpoint after cman start, as there is no
cman process itself (just corosync -f) you man to break right after
corosync is launched ?

That is exactly what I tried to do, I can see corosync starting with
no problem, but right after cman_tool join times out connecting to the
corosync.

I'm sure there are no errors in the cluster.conf (quite simple setup),
expected_votes=2, two_nodes=1 so the cluster should be able to start
with only one node.

Did anyone try this on FC12 ?

2010/3/23 Fabio M. Di Nitto <fdinitto redhat com>:
> On 3/23/2010 2:54 PM, Digimer wrote:
>> On 10-03-23 02:49 AM, Fabio M. Di Nitto wrote:
>>> On 3/7/2010 3:26 PM, brem belguebli wrote:
>>>> Hi,
>>>>
>>>> I'm fighting with cman on 2 FC12 VM's (KVM).
>>>>
>>>> I'm unable to start cman.
>>>>
>>>> Below my cluster.conf
>>>> ------------------------------------------------------------
>>>> <?xml version="1.0"?>
>>>> <cluster name="fccl1" config_version="3">
>>>>
>>>>    <clusternodes>
>>>>     <clusternode name="node1.localdomain" votes="1" nodeid="1"/>
>>>>     <clusternode name="node2.localdomain" votes="1" nodeid="2"/>
>>>>    </clusternodes>
>>>>     <cman expected_votes="2" two_node="1"/>
>>>>    <fencedevices>
>>>>    </fencedevices>
>>>>
>>>>    <rm>
>>>>      <failoverdomains/>
>>>>      <resources/>
>>>>    </rm>
>>>> </cluster>
>>>> --------------------------------------------------------------
>>>>
>>>> when running service cman start, it times out and complains that it
>>>> cannot join the cluster (timeout waiting for cluster), despite that
>>>> corosync is started.
>>>> Disabled selinux, nodes are referenced in each node's /etc/hosts.
>>>>
>>>> Any idea ?
>>>
>>> Try the following steps:
>>>
>>> 1) disable iptables
>>> 2) add<logging debug="on"/>  before<clusternodes>
>>> 3) try to start the cluster with: "/etc/init.d/cman start join"
>>>
>>> if it still fails, then please collect all the logs from
>>> /var/log/cluster.
>>>
>>> Point 3 is to break the init script at cman startup time. There is no
>>> point to load everything else if cman doesn´t work.
>>>
>>> If the cluster starts, then verify with "cman_tool status" and
>>> "cman_tool nodes" that the nodes can see each other and then you can
>>> simply execute again "service cman start" to start all the other cluster
>>> components.
>>>
>>> Fabio
>>
>> It could also be because there are no fence devices. A fence device is a
>> requirement, and without it, the cluster will block.
>>
>
> No, cman doesn´t care about fencing configuration to join the cluster.
> If he is getting timeout errors, it´s probably because of iptables or
> the nodes can´t talk multicast between them for some other reasons.
>
> Fabio
>
> --
> Linux-cluster mailing list
> Linux-cluster redhat com
> https://www.redhat.com/mailman/listinfo/linux-cluster
>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]