[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] Unable to start cman on FC12 VM's Cluster3



On 3/23/2010 5:57 PM, brem belguebli wrote:
> Hi,
> 
> Indeed, I tried configuring fence devices but no success.
> 
> Iptables are disabled, and even multicast was replaced by broadcat in
> the cluster.conf with no success.

I never tested broadcast so I can´t say. I´d leave it to multicast for
debugging.

> 
> I can ping the 255.255.255.255 from each cluster node, and I can see
> the traffic originated from both nodes when tcpdump'ing on host
> 255.255.255.255.
> 
> Fabio when you say put a breakpoint after cman start, as there is no
> cman process itself (just corosync -f) you man to break right after
> corosync is launched ?

Yes the breakpoint "join" will simply fire corosync -f with cman plugin
loaded and stop the init script there. There is no point to go any
further if the core doesn´t work.

It would also be helpful to know what version of the rpms you are using
(rpm -q -f /usr/sbin/cman_tool)

> 
> That is exactly what I tried to do, I can see corosync starting with
> no problem, but right after cman_tool join times out connecting to the
> corosync.

Ok, let´s do this in smaller steps then:

1) make sure no cluster daemons are running on the nodes.
2) enable debugging in the configuration as I explained in the previous
email
3) clean /var/log/cluster/* from old logs (we don´t need them anyway)
4) /etc/rc.d/init.d/cman start join

wait for timeout or a bit

collect output from:
cman_tool status
cman_tool nodes
/var/log/cluster/*

on all nodes and send them to me. No logs, no help :)

> 
> I'm sure there are no errors in the cluster.conf (quite simple setup),
> expected_votes=2, two_nodes=1 so the cluster should be able to start
> with only one node.
> 
> Did anyone try this on FC12 ?

Yes I regularly test all cluster releases on F12 before I do upstream
tarball releases.

Fabio


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]