[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] fence_apc and Apc AP-8941

When executed, the command above only display the error I mentionned (unable to connect). If I add --debug-file to the command line, the file id creates is empty.

I also tried by re-enabeling telnet instead of ssh, and I got the same result, except that now the debug file looks like :

telnet> set binary
Negotiating binary mode with remote host.
telnet> open -23
Connected to
Escape character is '^]'.

User Name : user
I replaced username and ip with fake ones.


If response is too fast then problem is in connecting information/process. If it took long enough (timeout problem) then it can be problem with change in command prompt. If it is possible please send me what it is displayed when you are trying to do it manually.

Response is indeed very fast when trying with the agent. With tcpdump on the node I try with the agent, I see ssh packets go to and from the apc switch.

When ssh-iing to the apc switch, it takes about 2 or 3 seconds before I get the password prompt, and then I see :
user 1 1 1 1's password:

American Power Conversion Network Management Card AOS v5.1.2 (c) Copyright 2009 All Rights Reserved RPDU 2g v5.1.0
Name      : Unknown                                   Date : 04/06/2011
Contact   : Unknown                                   Time : 10:52:44
Location  : Unknown                                   User : Device Manager
Up Time   : 0 Days 1 Hour 52 Minutes                  Stat : P+ N4+ N6+ A+

Type ? for command listing
Use tcpip command for IP address(-i), subnet(-s), and gateway(-g)

apc>qConnection to closed.

I think I have found the problem... Looking at fence_apc, I see :

options["ssh_options"] = "-1 -c blowfish"

Now, if I add this to my ssh command like so :

ssh -1 -c blowfish user 1 1 1 1

I get :

Protocol major versions differ: 1 vs. 2

So, there is no ssh version 1 on this version of the apc switrch. I commented out that line in /usr/sbin/fence_apc, and now the fence agent is able to establish the connection, but it cannot go any further.

The only thing that shows in my debug file is :

user 1 1 1 1's password:
[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]