[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] HP iLO3 and /sbin/fence_ilo not working



I think I mis-understood the article in combination with a reply from HP 
tech support on the issue. Looks like the fence_ipmilan agent is what 
changed to support fencing with iLO3, not fence_ilo.

linux-cluster-bounces redhat com wrote on 02/18/2011 12:47:17 PM:

> 
> According to this knowledge base article at redhat, https://access.
> redhat.com/kb/docs/DOC-39336, the /sbin/fence_ilo script should work
> with iLO3. I am using the version of cman mentioned in the article. 
> The iLO3 firmware is at the latest revision 1.16. 
> The fence_ilo script just returns a connect/login error as follows: 
> 
> [root node01 ~]# /sbin/fence_ilo -o status -a '10.39.170.233' -l 
> mitel -p ilopassword -v 
> Unable to connect/login to fencing device 
> 
> The login credentials are correct as I can connect via ssh: 
> 
> [root node01 ~]# ssh mitel 10 39 170 233 
> mitel 10 39 170 233's password: 
> User:mitel logged-in to ILOUSE103N281.(10.39.170.233) 
> iLO 3 Standard 1.16 at  Dec 17 2010 
> Server Name: host is unnamed 
> Server Power: On 
> 
> </>hpiLO-> 
> 
> Is their anything else that needs to be done to execute the script 
> successfully? The fence_ilo script works on previous iLO versions. 
> 
> 
> Linked Article: 
> 
> Issue 
> 
>     * How do I  set up HP iLO3 as a fence device in a Red Hat 
> Cluster Suite (RHCS) cluster? 
>     * Why does fencing fail on Red Hat Cluster Suite when using HP's 
iLO3? 
> 
> Environment 
> 
>     * Red Hat Enterprise Linux (RHEL) 5 
>     * Red Hat Enterprise Linux 6 
>     * Red Hat Cluster Suite 
>     * HP iLO3 
> 
> Resolution 
> 
> Support for the iLO3 fence device in RHEL5 has been added with the 
> release of cman 2.0.115-34.el5_5.4 through erratum RHEA-2010-0876. 
> No special setup is required after installing this erratum to get 
> the iLO3 to work. 
> 
> HP has also released new firmware to address an issue with 
> fence_ipmi which could cause the server to be powered on instead of 
> off. We therefore advise you to upgrade to firmware version 1.15 (28
> Oct 2010) as provided by HP. For installation instructions or 
> problem resolution with this firmware version we refer you to the HP 
website.
> 
> Root Cause 
> 
> HP iLO3 was not supported by fence_ilo.--
> Linux-cluster mailing list
> Linux-cluster redhat com
> https://www.redhat.com/mailman/listinfo/linux-cluster


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]