[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Linux-cluster] clamav upgrade issue



I have an old version (ie Ver 0.91.2-1.el4) currently running on my
RHES 4.x


First, I tried installing two releases' rpm of clamav but got the errors below:

# rpm -i ./clamd-0.96.5-1.el4.rf.i386.rpm
error: Failed dependencies:
        clamav = 0.96.5-1.el4.rf is needed by clamd-0.96.5-1.el4.rf.i386
        libclamav.so.6 is needed by clamd-0.96.5-1.el4.rf.i386
        libclamav.so.6(CLAMAV_PRIVATE) is needed by clamd-0.96.5-1.el4.rf.i386
        libclamav.so.6(CLAMAV_PUBLIC) is needed by clamd-0.96.5-1.el4.rf.i386
#
# rpm -i ./clamd-0.96.4-1.el4.rf.i386.rpm
error: Failed dependencies:
        clamav = 0.96.4-1.el4.rf is needed by clamd-0.96.4-1.el4.rf.i386
        libclamav.so.6 is needed by clamd-0.96.4-1.el4.rf.i386
        libclamav.so.6(CLAMAV_PRIVATE) is needed by clamd-0.96.4-1.el4.rf.i386
        libclamav.so.6(CLAMAV_PUBLIC) is needed by clamd-0.96.4-1.el4.rf



Second, I got another version of rpm from another site but this time it gave
a different problem.  This same problem persisted despite that I've uninstalled
(ie "rpm -e ... ") :

# rpm -i ./clamav-0.96.1-1.el4.rf.i386.rpm
        file /etc/freshclam.conf from install of clamav-0.96.1-1.el4.rf conflicts with file from package clamav-0.91.2-1.el4.rf
        file /usr/bin/clamscan from install of clamav-0.96.1-1.el4.rf conflicts with file from package clamav-0.91.2-1.el4.rf
        file /usr/bin/freshclam from install of clamav-0.96.1-1.el4.rf conflicts with file from package clamav-0.91.2-1.el4.rf
        file /usr/bin/sigtool from install of clamav-0.96.1-1.el4.rf conflicts with file from package clamav-0.91.2-1.el4.rf
        file /usr/share/man/man1/clamscan.1.gz from install of clamav-0.96.1-1.el4.rf conflicts with file from package clamav-0.91.2-1.el4.rf
        file /usr/share/man/man1/freshclam.1.gz from install of clamav-0.96.1-1.el4.rf conflicts with file from package clamav-0.91.2-1.el4.rf
        file /usr/share/man/man1/sigtool.1.gz from install of clamav-0.96.1-1.el4.rf conflicts with file from package clamav-0.91.2-1.el4.rf
        file /usr/share/man/man5/freshclam.conf.5.gz from install of clamav-0.96.1-1.el4.rf conflicts with file from package clamav-0.91.2-1.el4.rf


# rpm -e clamd-0.91.2-1.el4.rf
# rpm -qa | grep clam    <== this verified the above old rpm is deinstalled

When I repeated "rpm -i ./clamav-0.96.1-1.el4.rf.i386.rpm" above, it still gave
the same "conflicts" errors.  I also tried renaming the above 8 conflicting
files & reinstall but it still gave the same error

So what do I do next?


Thanks
U



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]