[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] fence_ipmilan fails to reboot - SOLVED



Hi all,

Thanks for your responses, after providing auth=password; fencing succeeded

                <fencedevice agent="fence_ipmilan" auth="password" ipaddr="IP" login="admin" name="IPMI_1" passwd="password"/>

Thanks,
Parvez


On Fri, Jul 1, 2011 at 2:33 PM, שלום קלמר <sklemer gmail com> wrote:
Hi.

I think you need to add the power_wait"10" & lanplus="1"

Try this line:

fencedevice agent="fence_ipmilan" power_wait="10" ipaddr="xx.xx.xx.xx" lanplus="1" login="xxxt" name="node1_ilo" passwd="yyy


Regards

Shalom.

On Thu, Jun 30, 2011 at 1:03 PM, Parvez Shaikh <parvez h shaikh gmail com> wrote:
Hi all,

I am on RHEL 5.5; and I have two rack mounted servers with IPMI configured.

When I run command from the prompt to reboot the server through fence_ipmilan, it shutsdown the server fine but it fails to power it on

# fence_ipmilan -a <IPMI IP Address> -l admin -p password -o reboot
Rebooting machine @ IPMI:<IPMI IP Address>...Failed

But I can power it on or power off just fine

# fence_ipmilan -a <IPMI IP Address> -l admin -p password -o on
Powering on machine @ IPMI:<IPMI IP Address>...Done

Due to this my fencing is failing and failover is not happening.

I have questions around this -

1. Can we provide action (off or reboot) in cluster.conf for ipmi lan fencing?
2. Is there anything wrong in my configuration? Cluster.conf file is pasted below
3. Is this a known issue which is fixed in newer versions

Here is how my cluster.conf looks like -
<?xml version="1.0"?>
<cluster config_version="4" name="Cluster">
 <fence_daemon post_fail_delay="0" post_join_delay="3"/>
 <clusternodes>
  <clusternode name="blade1.domain" nodeid="1" votes="1">
   <fence>
    <method name="1">
     <device lanplus="" name="IPMI_1"/>
    </method>
   </fence>
  </clusternode>
  <clusternode name="blade2.domain" nodeid="2" votes="1">
   <fence>
    <method name="1">
     <device lanplus="" name="IPMI_2"/>
    </method>
   </fence>
  </clusternode>
 </clusternodes>
 <cman expected_votes="1" two_node="1"/>
 <fencedevices>
  <fencedevice agent="fence_ipmilan" auth="none" ipaddr="<IMPI 1 IP Address>" login="admin" name="IPMI_1" passwd="password"/>
  <fencedevice agent="fence_ipmilan" auth="none" ipaddr="<IMPI 2 IP Address>" login="admin" name="IPMI_2" passwd="password"/>
 </fencedevices>
 <rm>
  <failoverdomains>
   <failoverdomain name="FailoveDomain" ordered="1" restricted="1">
    <failoverdomainnode name="blade1.domain" priority="2"/>
    <failoverdomainnode name="blade2.domain" priority="1"/>
   </failoverdomain>
  </failoverdomains>
  <resources/>
  <service autostart="1" name="service" recovery="relocate"/>
 </rm>
</cluster>
Thanks,
Parvez



--
Linux-cluster mailing list
Linux-cluster redhat com
https://www.redhat.com/mailman/listinfo/linux-cluster


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]