[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] Fencing Issues: fence_node fails but fence_ipmilan works



Hi,

 

I had a similar issue on an IBM M3 system although it was on a rhel5u6. The way we got it fix was by changing the ipmilam configuration *location*(attribute lanplus="1" in device element to fencedevice element) in the cluster.conf file, I am not sure if this would be relevant to you but just in case ….

 

I.E.

 

<method name="1">
<device name="m3vgc1b-ilo" action=""> <device name="fcswitch1" port="2"/>
<device name="fcswitch2" port="2"/>
</method>

<method name="1">
<device name="m3vgc1a-ilo" action=""> <device name="fcswitch1" port="1"/>
<device name="fcswitch2" port="1"/>
</method>


<fencedevice agent="fence_ipmilan" power_wait="10" ipaddr="XXX.XXX.XXX.XXX" lanplus="1" login="Admin" name="m3vgc1b-ilo" passwd="***"/>
<fencedevice agent="fence_ipmilan" power_wait="10" ipaddr="XXX.XXX.XXX.XXX" lanplus="1" login="Admin" name="m3vgc1a-ilo" passwd="***"/>

 

 

Regards,

 

Raúl Martínez Sánchez

 

From: linux-cluster-bounces redhat com [mailto:linux-cluster-bounces redhat com] On Behalf Of POWERBALL ONLINE
Sent: Monday, June 06, 2011 11:47 AM
To: linux clustering
Subject: Re: [Linux-cluster] Fencing Issues: fence_node fails but fence_ipmilan works

 

Please give me the cluster.conf file

On Mon, Jun 6, 2011 at 2:53 PM, Manish Kathuria <mkathuria tuxtechnologies co in> wrote:

I am facing a strange problem configuring a two node cluster using
RHCS 4.8. Both nodes are HP Proliant DL 180 G6 servers using HP LO
100i (IPMI Based).

When I run the fence_node command to check the fence device
configuration for either of the nodes, it fails giving the following
message in the logs:

fence_node[nnnn]: Fence of "node1" was unsuccessful
fence_node[nnnn]: Fence of "node2" was unsuccessful

However, when I run the fence_impilan command using the same
credentials, it executes successfully and is able to switch on, off
and reboot the nodes. The cluster configuration for the fence devices
is:

IPMI Lan Type
Name:           lo1
IP Address:     172.16.1.x
Login           admin
Password        passone
Auth Type       password

Name:           lo2
IP Address:     172.16.1.y
Login           admin
Password        passtwo
Auth Type       password

I have already tried different options for Auth Type (blank, password,
md5). Have also tried using / not using lanplus for both the fence
devices in the Manage Fencing dialog without success.

Any suggestions ?

Thanks,

Manish Kathuria

--
Linux-cluster mailing list
Linux-cluster redhat com
https://www.redhat.com/mailman/listinfo/linux-cluster

 




**************************************************************************************
This message is confidential and intended only for the addressee. If you have received this message in error, please immediately notify the postmaster nds com and delete it from your system as well as any copies. The content of e-mails as well as traffic data may be monitored by NDS for employment and security purposes. To protect the environment please do not print this e-mail unless necessary.

NDS Limited. Registered Office: One London Road, Staines, Middlesex, TW18 4EX, United Kingdom. A company registered in England and Wales. Registered no. 3080780. VAT no. GB 603 8808 40-00
**************************************************************************************

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]