[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Linux-cluster] Cannot migrate VM's



I upgraded Red Hat Enterprise Linux Server release 5.6 to try and solve some problems with an inherited broken cluster. After some effort I was able to migrate to the upgraded machine last night. This morning I upgraded the second machine and all seemed to go well until I tried to migrate the VM's back. The system just hangs and nothing happens whether I use virsh or Virtual Machine Manager.

From the machine with the vm's currently running:

May 19 09:48:26 julius libvirtd: 09:48:26.384: error : qemuDomainMigrateSetMaxDowntime:11792 : invalid argument in qemuDomainMigrateSetMaxDowntime: unsupported flags (0xbc614e) May 19 09:48:26 julius libvirtd: 09:48:26.400: error : qemuDomainMigrateSetMaxDowntime:11792 : invalid argument in qemuDomainMigrateSetMaxDowntime: unsupported flags (0xbc614e) May 19 09:49:04 julius libvirtd: 09:49:04.957: error : qemuDomainWaitForMigrationComplete:5066 : operation failed: Migration was cancelled by client


From the machine trying to migrate too:

May 19 09:43:11 justinian libvirtd: 09:43:11.682: warning : qemudStartup:1662 : Unable to create cgroup for driver: No such device or address

May 19 09:48:25 justinian libvirtd: 09:48:25.202: error : qemudDomainGetVcpus:5993 : Requested operation is not valid: cannot list vcpu pinning for an inactive domain May 19 09:48:25 justinian libvirtd: 09:48:25.208: error : qemuDomainGetJobInfo:11726 : Requested operation is not valid: domain is not running May 19 09:48:25 justinian libvirtd: 09:48:25.230: error : qemudDomainGetVcpus:5993 : Requested operation is not valid: cannot list vcpu pinning for an inactive domain May 19 09:48:25 justinian libvirtd: 09:48:25.235: error : qemuDomainGetJobInfo:11726 : Requested operation is not valid: domain is not running May 19 09:48:25 justinian libvirtd: 09:48:25.256: error : qemudDomainGetVcpus:5993 : Requested operation is not valid: cannot list vcpu pinning for an inactive domain May 19 09:48:25 justinian libvirtd: 09:48:25.262: error : qemuDomainGetJobInfo:11726 : Requested operation is not valid: domain is not running May 19 09:48:25 justinian libvirtd: 09:48:25.279: error : qemudDomainGetVcpus:5993 : Requested operation is not valid: cannot list vcpu pinning for an inactive domain May 19 09:48:25 justinian libvirtd: 09:48:25.285: error : qemuDomainGetJobInfo:11726 : Requested operation is not valid: domain is not running May 19 09:48:25 justinian libvirtd: 09:48:25.347: error : qemudDomainGetVcpus:5993 : Requested operation is not valid: cannot list vcpu pinning for an inactive domain May 19 09:48:25 justinian libvirtd: 09:48:25.353: error : qemuDomainGetJobInfo:11726 : Requested operation is not valid: domain is not running May 19 09:49:13 justinian libvirtd: 09:49:13.006: error : qemuDomainObjBeginJob:362 : Timed out during operation: cannot acquire state change lock May 19 09:49:13 justinian libvirtd: 09:49:13.827: error : qemudDomainBlockStats:9500 : Requested operation is not valid: domain is not running

From:
http://libvirt.org/drvqemu.html

I tried:
mkdir /dev/cgroup
mount -t cgroup none /dev/cgroup -o devices

[root julius vmdata]# mount -t cgroup none /dev/cgroup -o devices
mount: unknown filesystem type 'cgroup'

Any help would be appreciated.
Thank You
Ken Lowther





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]