[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] How to run same service in parallel in RedHat Cluster 5.0



Here is the cluster.conf (didn't get access to run other commands yet) :

<?xml version="1.0"?>
<cluster alias="PPM_CL1" config_version="81" name="PPM_CL1">
        <fence_daemon clean_start="0" post_fail_delay="0"
post_join_delay="30"/>
        <clusternodes>
                <clusternode name="server-87111" nodeid="1" votes="2">
                        <fence/>
                </clusternode>
                <clusternode name="server-87112" nodeid="2" votes="1">
                        <fence/>
                </clusternode>
        </clusternodes>
        <cman expected_votes="1">
                <multicast addr="224.4.5.6"/>
        </cman>
        <fencedevices/>
        <rm>
                <failoverdomains>
                        <failoverdomain name="PPM_GW_FDN" nofailback="1"
ordered="0" restricted="1">
                                <failoverdomainnode name="server-87111"
priority="1"/>
                        </failoverdomain>
                        <failoverdomain name="PPM_UNIT_FDN" nofailback="1"
ordered="0" restricted="1">
                                <failoverdomainnode name="server-87112"
priority="1"/>
                        </failoverdomain>
                </failoverdomains>
                <resources>
                        <ip address="10.116.159.105" monitor_link="1"/>
                        <script file="/usr/local/bin/cluster/ppm_gw_ha"
name="PPM_GW"/>
                        <fs device="/dev/mapper/VolGroup00-optvol"
force_fsck="1" force_unmount="0" fsid="36845" fstype="ext3"
mountpoint="/opt" name="PPM_OPT_FS" self_fence="0"/>
                        <apache config_file="conf/httpd.conf" name="web"
server_root="/etc/httpd" shutdown_wait="0"/>
                        <clusterfs device="/dev/hdd" force_unmount="0"
fsid="20023" fstype="gfs" mountpoint="/mnt" name="pru1" self_fence="0"/>
                </resources>
                <service autostart="0" exclusive="0" name="PPM_PRUEBA"/>
                <service autostart="0" domain="PPM_UNIT_FDN" exclusive="0"
name="PPM Units">
                        <fs ref="PPM_OPT_FS"/>
                </service>
                <service autostart="0" domain="PPM_GW_FDN" exclusive="0"
name="PPM Gateway">
                        <fs ref="PPM_OPT_FS">
                                <ip ref="10.116.159.105">
                                        <script ref="PPM_GW"/>
                                </ip>
                        </fs>
                </service>
        </rm>
</cluster>


On 27-Sep-2011 8:45 PM, "Digimer" <linux alteeve com> wrote:

> On 09/27/2011 05:33 PM, Ruben Sajnovetzky wrote:
>> 
>> I might be doing something wrong, because you say "you are fine" but didn't
>> work :(
>> 
>> All servers have "/opt/app" mounted in same internal disk partition.
>> They are not shared, it is just that all have identical layout.
>> I tried to create:
>> 
>>     Resource name: Central_FS
>>     Device: /dev/mapper/VolGroup00-optvol
>>     FS Type: ext3
>>     Mount point: /opt
>> 
>> And
>> 
>>     Resource name: Collector_FS
>>     Device: /dev/mapper/VolGroup00-optvol
>>     FS Type: ext3
>>     Mount point: /opt
>> 
>> When I tried to save it I found in the /var/log/messages:
>> 
>>  clurgmgrd[4174]: <notice> Reconfiguring
>>  clurgmgrd[4174]: <err> Unique attribute collision. type=fs attr=mountpoint
>> value=/opt 
>>  clurgmgrd[4174]: <err> Error storing fs resource
>>     
>> Thanks for your help and ideas!
> 
> Please post your cluster.conf file (and obfuscate only passwords,
> please). Also post a sample /etc/fstab and the outputs of 'pvscan',
> 'vgscan' and 'lvscan'.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]