[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] Few queries about fence working



I think you have fencing-race problem, try to look man fence_drac6

try to delay fencing on a node when have problem with the cluster network

=======================================
 --delay
              Wait X seconds before fencing is started (Default Value: 0)
========================================

And i see you don't have a quorum disk, using qdisk for redhat it's always a good idea
2012/1/25 jayesh.shinde <jayesh shinde netcore co in>
Dear  Emmanuel Segura,

Find the config below.  Because of policy I have removed some login details.

#############

<?xml version="1.0"?>
<cluster config_version="6" name="new_cluster">
        <fence_daemon post_fail_delay="0" post_join_delay="3"/>
        <clusternodes>
                <clusternode name="mailbox1" nodeid="1" votes="1">
                        <multicast addr="224.0.0.1" interface="bond0"/>
                        <fence>
                                <method name="1">
                                        <device name="imap1drac"/>
                                </method>
                        </fence>
                </clusternode>
                <clusternode name="mailbox2" nodeid="2" votes="1">
                        <multicast addr="224.0.0.1" interface="bond0"/>
                        <fence>
                                <method name="1">
                                        <device name="imap2drac"/>
                                </method>
                        </fence>
                </clusternode>
        </clusternodes>
   <cman expected_votes="1" two_node="1">
           <multicast addr="224.0.0.1"/>
   </cman>
        <fencedevices>
                <fencedevice agent="fence_drac6" ipaddr="<drac IP>" login="<login name>" name="imap1drac" passwd="xxxxx"/>
                <fencedevice agent="fence_drac6" ipaddr="<drac IP>" login="<login name>" name="imap2drac" passwd="xxxxx"/>
        </fencedevices>
        <rm>
                <failoverdomains/>
                <resources>
                        <ip address="192.168.1.1" monitor_link="1"/>
                        <fs device="/dev/drbd0" force_fsck="0" force_unmount="1" fsid="28418" fstype="ext3" mountpoint="/mount/path" name="imap1_fs" options="rw" self_fence="1"/>
                        <script file="/etc/init.d/cyrus-imapd" name="imap1_init"/>
                </resources>
                <service autostart="1" name="imap1" recovery="restart">
                        <ip ref="192.168.1.1"/>
                        <fs ref="imap1_fs"/>
                        <script ref="imap1_init"/>
                </service>
        </rm>
</cluster>
###################

Regards
Jayesh Shinde


On 01/25/2012 01:59 PM, emmanuel segura wrote:
Can you show me your cluster config?

2012/1/25 jayesh.shinde <jayesh shinde netcore co in>
Hi  all ,

I have few queries about fence working.

I am using 2 different  the 2 node cluster with Dell and IBM hardware in two different IDC.
Recently I came across the network failure problem at different time and I found my 2 nodes are power off state.

Below is  how the situation happened with my 2 different 2 node cluster.

With 2 node
IBM  node cluster with SAN :--
==============================
1)  Network connectivity  was failed totally for few minutes.
2) And as per the /var/log/messages both servers failed to  fence to each other and both server was UP as it is with all services.
3) But the "clustat" was showing serves are not in cluster mode and "regmanger" status was stop.
4) I simply reboot the server.
5) After that I found both server in power off stat.


with another  2 node Dell server with DRBD  :--
=================================
1)
Network connectivity  was failed totally.
2) DRAC ip was unavailable so fence failed from both server.
3) after some time I fond the servers are shutdown.

In normal conditions both cluster work properly

 my queries are now :--
 ===============
1) What could be the reason for power off ?
2) Does cluster's fencing method  caused for the power off  of server ( i.e because of previous failed fence ) ?
3) Is there any test cases mentioned on net / blog / wiki  about the fence , i.e different situation under which  fence works.

Please guide.

Thanks & Regards
Jayesh Shinde




--
Linux-cluster mailing list
Linux-cluster redhat com
https://www.redhat.com/mailman/listinfo/linux-cluster



--
esta es mi vida e me la vivo hasta que dios quiera
-- Linux-cluster mailing list Linux-cluster redhat com https://www.redhat.com/mailman/listinfo/linux-cluster


--
Linux-cluster mailing list
Linux-cluster redhat com
https://www.redhat.com/mailman/listinfo/linux-cluster



--
esta es mi vida e me la vivo hasta que dios quiera

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]