[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] Error mounting lockproto lock_dlm [SOLVED]



Le 04/06/2012 11:24, Nicolas Ecarnot a écrit :
Hi,

I had a 2-nodes cluster running too fine under Ubuntu server 11.10, with
cman, corosync, GFS2, OCFS2, clvm, ctdb, samba, winbind.

So I decided to upgrade :)

Under Precise (12.04), my OCFS2 partition is still working well.
CLVM is still OK, nicely speaking with the dlm layer (dlm_controld).

I ran "dlm_controld -D" and I can see the nice interaction with clvmd
when ran.

But when I try to mount any GFS2 partition (either directly with
mount.gfs2, or via the init.d script), I get the good old error:

| gfs_controld join connect error: Connection refused
| error mounting lockproto lock_dlm

When getting this, I don't see the smallest contact with dlm_controld
(ran with -D, it should blink somewhere).


I guess something has changed

Dear me :)

Check these pages and their diffs:
- http://manpages.ubuntu.com/manpages/oneiric/man8/gfs_controld.8.html
- http://manpages.ubuntu.com/manpages/precise/man8/gfs_controld.8.html

Especialy look at the second line :
Provided by: ...

Was provided by the package cman, and is now provided by the package gfs2-cluster...

Ubuntu, I like you, but you're sometimes hard to follow...

--
Nicolas Ecarnot


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]