[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Linux-cluster] Nodes don't Power Off on halt



Hi

On my 2 node clusters I have a UPS connected to them. This UPS is
programmed to shutdown both nodes of the clusters. Node 2 shutsdown
several minutes before node 1.

The fence mechanisms I have setup are primarily an APC network power
switch and for backup Dell DRAC with fence_ipmilan.

If you shutdown a node where the cluster services are chkconfig'd on,
and it withdraws cleanly from the cluster on shutdown it sits at system
halted and doesn't power off.

If no cluster services have ever been started (all chkconfig'd off) and
the system is shutdown, it halts and powers off.

Now I know the recommendation is for acpi to be turned off but it makes
no difference either way, and I have verified both fence mechanisms
power hard down the system acpid or not.

By not powering down, the UPS continues to have power drawn from it
until it's power off timer expires (that the last node send it in
halt.local). This has the effect of needlessly reducing battery capacity
and lowering protection from multiple consecutive power outages.

What causes the system not to power down, I realise this maybe by
design, but is it configurable?

Thanks

Colin


________________________________


This email and any files transmitted with it are confidential and are intended solely for the use of the individual or entity to whom they are addressed. If you are not the original recipient or the person responsible for delivering the email to the intended recipient, be advised that you have received this email in error, and that any use, dissemination, forwarding, printing, or copying of this email is strictly prohibited. If you received this email in error, please immediately notify the sender and delete the original.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]