[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] Questionas about fence_vmware_soap



On 03/02/2012 10:09 AM, Masopust, Christian wrote:

Hi,

I don't know fence_vmware_soap but for ESXi 4.1 I've written
a "fence_esxi" (based on fence_apc) which connects by ssh and
simply powers on/off the VM by means of "vim-cmd".

Please send me a private mail if you like to have it :)

br,
christian


Ok, I have tried to configure it (fence_vmware_soap):

<cluster config_version="1" name="VMwareCluster">
	<cman expected_votes="1" two_node="1"/>
	<logging to_logfile="yes" to_syslog="yes"/>
	<clusternodes>
		<clusternode name="firstnode.domain.com" nodeid="1">
			<fence>
				<method name="1">
<device name="esxi-resort" port="rhelnode01" uuid="564dee4b-7107-f6c5-608e-dd781fac9847"/>
				</method>
			</fence>
		</clusternode>
		<clusternode name="secondnode.domain.com" nodeid="2">
			<fence>
			</fence>
		</clusternode>
	</clusternodes>
	<fencedevices>
<fencedevice agent="fence_vmware_soap" ipaddr="172.25.50.8" login="root" passwd="mypass" ssl="1" name="esxi-resort"/>
		<fencedevice agent="fence_ack_manual" name="last-resort"/>
	</fencedevices>
......

 ... and it seems it works, but ....

[root firstnode cluster]# clustat
Cluster Status for VMwareCluster @ Fri Mar  2 22:16:04 2012
Member Status: Quorate

Member Name ID Status ------ ---- ---- ------ firstnode.domain.com 1 Online, Local
 secondnode.domain.com                                         2 Offline


... and when I try to start clvmd:

[root firstnode log]# service clvmd start
Starting clvmd: clvmd startup timed out

and group_tool output:

[root firstnode cluster]# group_tool
fence domain
member count  1
victim count  1
victim now    2
master nodeid 1
wait state    fencing
members

dlm lockspaces
name          clvmd
id            0x4104eefa
flags         0x00000015 need_plock,kern_stop,join
change        member 0 joined 0 remove 0 failed 0 seq 0,0
members
new change    member 1 joined 1 remove 0 failed 0 seq 1,1
new status    wait_messages 0 wait_condition 1 fencing
new members   1


.. and I can't configure shared storage with lvm tools because they doesn't works ... Where is the problem?' Do I need to setup a quorum device??

Still I have not configured second node ...

--
CL Martinez
carlopmart {at} gmail {d0t} com


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]