[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] cannot run cluster service



I don't think you addressed any of my comments.

On 10/10/2012 11:02 PM, Shanti Pahari wrote:
Thanks!

I updated the fencing method in each of the nodes. But after I added
volume_list = [ "vg_pdcpicpl02", "@PDC-PIC-PL-CL1", "@PDC-PIC-PL-CL2" ]
and
# dracut --hostonly --force /boot/initramfs-$(uname -r).img $(uname -r)
# shutdown -r now "Activating ramdisk LVM changes"

After that when the system tries to boot up:
Kernel panic – not syncing: Attempted to kill init!

So didn’t have luck 

Can you help me pls!

-----Original Message-----
From: Digimer [mailto:lists alteeve ca]
Sent: Wednesday, 10 October, 2012 11:51 PM
To: linux clustering
Cc: Shanti Pahari
Subject: Re: [Linux-cluster] cannot run cluster service

Your fencing is not setup properly. You define the fence devices, but do not
use them as <method>'s under each node definition. You should be able to
'fence_node <target>' and watch it get rebooted. Until then, your cluster
will hang (by design) the first time there is a problem.

Assuming you want to use clustered LVM, you need to change locking_type to
'3' and, I advise, change 'falllback_to_local_locking' to '0'. This also
requires that the 'clvmd' daemon is running, which in turn needs cman to be
running first.

What is your backing device for the LVM PV?

digimer

On 10/10/2012 03:06 AM, Shanti Pahari wrote:
Dear all,

I have cluster setup with 2 node and created web cluster service on it
but it cannot run.

I have not listed anything in lvm.conf volume_list because once I add
anything in volume_list and reboot the system then I cannot mount and
even cannot read the lv which I created for my web . It throws error
as

error message "not activating volume group lv does not pass activation
filter"

Therefore I didn’t add anything in lvm.conf . Then I try to start my
cluster servers for web server but the service failed.

Please help me so that I can solve this out.

I have attached my cluster.conf , lvdisplay , /var/log/messages and
lvm.conf and my /etc/hosts.

I will be greatful if anyone can help me!

Thanks

And my clustat:

Cluster Status for PDC-PIC-PL-CL @ Wed Oct 10 14:58:05 2012

Member Status: Quorate

Member Name                                                     ID
Status

------ ----                                                     ---- ------

PDC-PIC-PL-CL1                                                      1
Online, Local, rgmanager

PDC-PIC-PL-CL2                                                      2
Online, rgmanager

Service Name                                               Owner
(Last)                                               State

   ------- ----                                               -----
------                                               -----

   service:ha-web-service
(PDC-PIC-PL-CL1)                                           failed





--
Digimer
Papers and Projects: https://alteeve.ca/w/ "Hydrogen is just a colourless,
odorless gas which, if left alone in sufficient quantities for long periods
of time, begins to think about itself."



--
Digimer
Papers and Projects: https://alteeve.ca/w/
"Hydrogen is just a colourless, odorless gas which, if left alone in sufficient quantities for long periods of time, begins to think about itself."


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]