[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] Cannot connect to rgmanager



did you started rgmanager?

2013/2/19 Maxwell, Jamison [HDS] <JMaxwell pbp1 com>

I am attempting to create a two node cluster where the only resource required would be a shared IP address, however, after a couple of attempts I continue to fail.  I have followed a guide located at http://www.openlogic.com/wazi/bid/188071/ .  Everything appears to work fine until I get to the point where I actually add the IP address resource, both cluster nodes appear as online and quorate and the configuration validates, but will not enable the new resource.  Below I am including any information that I think may be relevant, but feel free to ask for more.

 

===========================================

[root@ hostname]# cat /etc/cluster/cluster.conf

<?xml version="1.0"?>

<cluster config_version="4" name="hacluster">

        <cman expected_votes="1" two_node="1"/>

        <clusternodes>

                <clusternode name="actual name of node" nodeid="1" votes="1">

                        <fence>

                                <method name="single"/>

                        </fence>

                </clusternode>

                <clusternode name=" actual name of node " nodeid="2" votes="1">

                        <fence>

                                <method name="single"/>

                        </fence>

                </clusternode>

        </clusternodes>

        <fencedevices/>

        <rm>

                <failoverdomains/>

                <resources/>

                <service autostart="1" exclusive="0" name="IP" recovery="relocate">

                        <ip address="actual shared IP address" monitor_link="on" sleeptime="10"/>

                </service>

        </rm>

</cluster>

===========================================

 

[root@ hostname]# clusvcadm -e IP

Local machine trying to enable service:IP...Could not connect to resource group manager

===========================================

 

[root@ hostname]# strace clusvcadm -e IP

connect(5, {sa_family=AF_FILE, path="/var/run/cluster/rgmanager.sk"}, 110) = -1 ENOENT (No such file or directory)

close(5)                                = 0

write(1, "Could not connect to resource gr"..., 44Could not connect to resource group manager

) = 44

exit_group(1)                           = ?

===========================================

 

I would most like to call your attention to the line “write(1, " connect(5, {sa_family=AF_FILE, path="/var/run/cluster/rgmanager.sk"}, 110) = -1 ENOENT (No such file or directory)”.  There was also a someone who mailed this list with what appears to be the same problem, however, no issue is present in the conversation.  The topic is located here: http://www.redhat.com/archives/linux-cluster/2012-August/msg00156.html

 

This is version 6.3, no iptables and no selinux until I can get this working.  I greatly appreciate any assistance that can be offered.

 

 

Jamison Maxwell
Sr. Systems Administrator
HD Suppy - Facilities Maintenance

 


--
Linux-cluster mailing list
Linux-cluster redhat com
https://www.redhat.com/mailman/listinfo/linux-cluster



--
esta es mi vida e me la vivo hasta que dios quiera
[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]