[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Linux-cluster] GFS2 File System mount failing




I am facing few issues while creating a GFS2 file system . GFS2 file creation is successful , but  it is failing while trying to mount the file system .

It is failing with the following error :

===
[root eser~]# /etc/init.d/gfs2 start
Mounting GFS2 filesystem (/sharedweb): fs is for a different cluster
error mounting lockproto lock_dlm
                                                           [FAILED]
----------

[root eser ~]# tail -f /var/log/messages
Jan 30 15:50:27 eser modcluster: Updating cluster version
Jan 30 15:50:27 eser corosync[7121]:   [QUORUM] Members[2]: 1 2
Jan 30 15:50:28 eser rgmanager[7379]: Reconfiguring
Jan 30 15:50:28 eser rgmanager[7379]: Loading Service Data
Jan 30 15:50:29 eserrgmanager[7379]: Stopping changed resources.
Jan 30 15:50:29 eser rgmanager[7379]: Restarting changed resources.
Jan 30 15:50:29 eser rgmanager[7379]: Starting changed resources.
Jan 30 15:56:21 eser gfs_controld[7254]: join: fs requires cluster="mycluster" current="sharedweb"
Jan 30 16:02:43 eser gfs_controld[7254]: join: fs requires cluster="mycluster" current="sharedweb"
Jan 30 18:46:48 eser gfs_controld[7254]: join: fs requires cluster="mycluster" current="sharedweb"

  ==========

"sharedweb" is the cluster which I created earlier and created the GFS2 file system using this cluster name. But I deleted "sharedweb" cluster and created a new cluster called "mycluster" , but while mounting the GFS2 partition with the new cluster , it is showing the error as mentioned above .

I created the new GFS2 file system using the command as shown below

mkfs.gfs2 -t mycluster:mygfs2 -p lock_dlm -j 2 /dev/mapper/mpathcp1

My cluster config is as follows:

=====
# cat /etc/cluster/cluster.conf
<?xml version="1.0"?>
<cluster config_version="2" name="mycluster">
        <clusternodes>
                <clusternode name="eser.xxx.com" nodeid="1"/>
                <clusternode name="www.xxxxx.com" nodeid="2"/>
        </clusternodes>
        <cman expected_votes="1" two_node="1"/>
</cluster>
===

Please suggest how to resolve the issue


Thanks
Zaman

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]