[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] luci question



On 29/04/14 16:02 +0000, Neale Ferguson wrote:
> luci-0.26.0-48 (tried -13 as well)
> TurboGears2-2.0.3-4.
> kernel-2.6.32-358.2.1
> python-repoze-who-1.0.18-1 (I believe - am verifying)

Thanks, this looks sane.

Actually there used to be an issue with Genshi generating strict
XML by default, notably baffling IE, but it should be sufficiently
solved for a long time (https://bugzilla.redhat.com/663103),
definitely in the version you used.

Just to be sure could you provide also your python-genshi version?


Now I am thinking about another thing:

> One of the guys created a simple configuration

seems to be pretty generic expression, and makes me confused.  Does it
mean mere luci installation/deployment (along the lines of what
specfile does, or better yet, directly from package), or (also) some
configuration files tweaking (having especially
/var/lib/luci/etc/luci.ini in mind, modifying file analogous to
/etc/sysconfig/luci should be fine)?

Because if the latter, chances are that admittedly a bit fragile
start up process involving hierarchical configuration (via two stated
files) and intentional run-time substitutions of middleware
initialization routines (cf. luci.initwrappers) could suffer from
that.  On the other hand, if logging in works as expected, even when
reproduced with cookies previously cleared, the issue remains
a mystery. [If it meant a _cluster_ configuration in luci, I don't
think this has any relevance to the issue.]


Also to this point:

> the links "Admin ... Logout" at the top left of the window that
> usually appears is not appearing.

not even "Login" is shown at that very position, right?


Further debugging pointers:

- inspect source code of the generated page, best when static original
  is preserved (some code inspectors tend to rather work with live,
  dynamically modified DOM serialization), wget/curl output when
  pretending being logged in via cookies might also help

- last and promise-less attempt: try enabling verbose logging in
  /var/lib/luci/etc/luci.ini or equivalent (substitute to fit):

# sed -i.old ':0;/\[logger_root\]/b1;p;d;:1;n;s|\(level[ \t]*=[ \t]*\).*|\1DEBUG|;t0;b1' \
  /var/lib/luci/etc/luci.ini

  followed by luci restart and accessing the page in question;
  there may be something suspicious in the log (usually
  /var/log/luci/luci.log) but expectedly amongst plenty
  of other/worthless messages :-/

> On Apr 29, 2014, at 11:18 AM, Jan Pokorný <jpokorny redhat com> wrote:
> 
>> could you be more specific as to which versions of luci, TurboGears
>> and repoze.who?  In RHEL-like distros, the latter map to TurboGears2
>> and python-repoze-who packages.
>> 
>> I don't recall any issue like what you described.

-- 
Jan

Attachment: pgpwkuHFyMRCI.pgp
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]