[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] Question about cluster behavior



Hello

On Monday 17 of February 2014 10:25:32 FABIO FERRARI wrote:
> Yes, I know that if I have only 1 machine active the cluster won't start
> with this configuration.
> But this is not my problem. My problem is that the cluster was not started
> even with 2 machines and the quorum disk active.
> There isn't any cluster.log in /var/log or in /var/log/cluster. Anyway, as
> you can see, there isn't ANY log line in all cluster log files between
> 8:30 and 9:00 of 11th february. Only /var/log/messages has some logs
> during this period.
> (Don't consider the errors between 8:00 and 8:30 because the storage was
> not active. At about 9:00 we started the third machine so after this hour
> it was all ok.)
>
>...
> 
> qdiskd.log
> Feb 07 17:41:52 qdiskd Unregistering quorum device.
> Feb 11 08:12:46 qdiskd Unable to match label 'mail-qdisk' to any device
> Feb 11 09:05:08 qdiskd Quorum Partition: /dev/block/253:0 Label: mail-qdisk

I am not an expert in this, but it seems you are using LVM volume as your 
qdisk.
I would expect an issue with this, since LVM uses DLM, which in turn depends 
on qdisk

This log seems to indicate that qdisk is not active untill the whole cluster 
is active, which basically defats its purpose

Regards,
Pavel


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]