[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] Introduction to clusters



Hello all,

Apologies for the top posting. I thought in-line reply might not help in this one.

So, this is where I am unable to figure out.

I have a Red Hat cluster that seems to be working fine. It consists of 2 Virtual Machines on VMWare. I have to configure HP OM service in this cluster. Components of this service are basically 3 logical volumes called /dev/shared-vg01/shared-vol1, /dev/shared-vg01/shared-vol2 and /dev/shared-vg01/shared-vol3 that need to be mounted on specific partitions and an IP address associated with this service.

In our setup, I am using VMWare SOAP as the fence device now. A week ago, one of the servers went for a reboot and then the whole cluster had failed. At that time, the fence device that was configured by a previous sys admin was SCSI. I saw that there is no SCSI device attached to the cluster and hence I thought this might be a cause of failover. While starting cman, I notice this error again and again -- "Unfencing self ... [failed]".

Once I made changes to the fencing device, I tested the failover of this cluster with an IP address and Apache service. If node1 goes down, Apache and IP address are brought alive on node2. When node1 comes up, it still stays on the node2, which is as expected. Now when node2 goes down, the service changes over to the node1. So, this seems to be working fine in fail over mode.

What I am unable to figure is this: When I try to add the particular HP OM server in this cluster as a service group, I can see only the IP address failing over, system logs and Luci interface say the service has moved over to the other node; but the shared logical volumes are never mounted. Service is active but logical volumes are never mounted. Where do I debug ?

Where am I failing ? vgs, lvs, pvs all show that shared-vg01 has got the attribute of "cluster". The cluster locking type in /etc/lvm/lvm.conf is set to 3. Still I am never able to mount the file systems. Clvmd is running, cman is running, rgmanager is running and none of them show any issues. I can mount the file systems manually but the cluster never mounts them.

Best,

Amitakhya Phukan

________________________________________
From: linux-cluster-bounces redhat com [linux-cluster-bounces redhat com] On Behalf Of Rajagopal Swaminathan [raju rajsand gmail com]
Sent: Tuesday, February 18, 2014 11:20 PM
To: linux clustering
Subject: Re: [Linux-cluster] Introduction to clusters

Greetings,

On Tue, Feb 18, 2014 at 3:05 AM, Phukan, Amitakhya
<Amitakhya Phukan williams com> wrote:
> I am new to Linux clusters. Need some help in getting around with it. Can
> someone point me to any beginner's guide etc.?
>

There are two kinds of clusters:
1. High Performance Clusters (HPC) -- essentially used for number crunching
2. High Availability Clusters

This list's focus is HA Clusters.

You can have a look at these:

https://alteeve.ca/w/Main_Page

especially

https://alteeve.ca/w/AN!Cluster_Tutorial_2

for HA Clusters.

Can you clarify further what kind of cluster you are looking for?


--
Regards,

Rajagopal

--
Linux-cluster mailing list
Linux-cluster redhat com
https://www.redhat.com/mailman/listinfo/linux-cluster


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]