Hi<br>Thanks for your advise,<br>Currently i got this<br><br>luci-0.12.2-12.el5.centos.1<br>ricci-0.12.2-12.el5.centos.1<br><br>is this the same rpm as <br><br>luci-0.12.2-12.el5_5.4.i386.rpm  ?<br>ricci-0.12.2-12.el5_5.4.i386.rpm  ?<br>
<br>Thanks<br><br><br><div class="gmail_quote">On 27 September 2010 17:55, Paul M. Dyer <span dir="ltr">&lt;<a href="mailto:pmdyer@ctgcentral2.com">pmdyer@ctgcentral2.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;">
<a href="http://rhn.redhat.com/errata/RHBA-2010-0716.html" target="_blank">http://rhn.redhat.com/errata/RHBA-2010-0716.html</a><br>
<br>
It appears that this problem has been fixed in this errata.<br>
<br>
I installed the luci and ricci updates and did some lite testing.   So far, the timeout 11111 error has not shown up.<br>
<br>
Paul<br>
<div><div></div><div class="h5"><br>
----- Original Message -----<br>
From: &quot;fosiul alam&quot; &lt;<a href="mailto:expertalert@gmail.com">expertalert@gmail.com</a>&gt;<br>
To: &quot;linux clustering&quot; &lt;<a href="mailto:linux-cluster@redhat.com">linux-cluster@redhat.com</a>&gt;<br>
Sent: Monday, September 27, 2010 10:48:27 AM<br>
Subject: Re: [Linux-cluster] ricci is very unstable in one nodes<br>
<br>
Hi<br>
i am trying to patch ricci . let see how it goes<br>
<br>
but clusvcadm is failing as well<br>
<br>
[root@http1 ~]# clusvcadm -e httpd1 -m http1.xxxx.local<br>
Member http1.xxxx.local trying to enable service:httpd1...Invalid<br>
operation for resource<br>
<br>
here, http1 , where i was trying to run the service from luci<br>
<br>
what could be the problem ?<br>
is there any way to find out if there is any problem with config ??<br>
<br>
On 27 September 2010 16:26, Ben Turner &lt; <a href="mailto:bturner@redhat.com">bturner@redhat.com</a> &gt; wrote:<br>
<br>
<br>
RHEL 5.6 hasn&#39;t been released yet so your package probably contains the<br>
problem. I&#39;m not sure how in sync Centos is with RHEL or if they patch<br>
earlier so I cannot give you a time frame when it will be in Centos or<br>
if they have already patched it. The problem in that BZ is more of an<br>
annoyance, you usually just have to retry a time or two and it works. If<br>
you can&#39;t get Luci working properly with your service at all you should<br>
try enabling the service through the command line with clusvcadm -e. If<br>
it is not working from the command line either then there is a problem<br>
with the service config.<br>
<br>
<br>
<br>
<br>
-Ben<br>
<br>
<br>
<br>
<br>
----- &quot;fosiul alam&quot; &lt; <a href="mailto:expertalert@gmail.com">expertalert@gmail.com</a> &gt; wrote:<br>
<br>
&gt; Hi Ben<br>
&gt; Thanks<br>
&gt;<br>
&gt; I named this cluster as mysql-server but i have not installed mysql<br>
&gt; database in their yet<br>
&gt;<br>
&gt; and both luci and ricci on luci server and node1 is running this<br>
&gt; version<br>
&gt;<br>
&gt; luci-0.12.2-12.el5.centos.1<br>
&gt; ricci-0.12.2-12.el5.centos.1<br>
&gt;<br>
&gt;<br>
&gt; do you think this version has problem as well ??<br>
&gt;<br>
&gt; thanks for your help<br>
&gt;<br>
&gt;<br>
&gt;<br>
&gt;<br>
&gt; On 24 September 2010 15:33, Ben Turner &lt; <a href="mailto:bturner@redhat.com">bturner@redhat.com</a> &gt; wrote:<br>
&gt;<br>
&gt;<br>
&gt; There is an issue with ricci timeouts that was fixed recently:<br>
&gt;<br>
&gt; <a href="https://bugzilla.redhat.com/show_bug.cgi?id=564490" target="_blank">https://bugzilla.redhat.com/show_bug.cgi?id=564490</a><br>
&gt;<br>
&gt; I&#39;m not sure but you may be hitting that bug. Symptoms include: luci<br>
&gt; isn&#39;t able to get the status from the node, timeouts when querying<br>
&gt; ricci, etc. The fix should be released with 5.6<br>
&gt;<br>
&gt; On the mysql service there are some options that you need to set. Here<br>
&gt; are all the options available to that agent:<br>
&gt;<br>
&gt; mysql<br>
&gt; Defines a MySQL database server<br>
&gt;<br>
&gt; Attribute Description<br>
&gt; config_file Define configuration file<br>
&gt; listen_address Define an IP address for MySQL server. If the address<br>
&gt; is not given then first IP address from the service is taken.<br>
&gt; mysqld_options Other command-line options for mysqld<br>
&gt; name Name<br>
&gt; ref Reference to existing mysql resource in the resources section.<br>
&gt; service_name Inherit the service name.<br>
&gt; shutdown_wait Wait X seconds for correct end of service shutdown<br>
&gt; startup_wait Wait X seconds for correct end of service startup<br>
&gt; __enforce_timeouts Consider a timeout for operations as fatal.<br>
&gt; __failure_expire_time Amount of time before a failure is forgotten.<br>
&gt; __independent_subtree Treat this and all children as an independent<br>
&gt; subtree. __max_failures Maximum number of failures before returning a<br>
&gt; failure to a status check.<br>
&gt;<br>
&gt; If I recall correctly you may need to tweak:<br>
&gt;<br>
&gt; shutdown_wait Wait X seconds for correct end of service shutdown<br>
&gt; startup_wait Wait X seconds for correct end of service startup<br>
&gt;<br>
&gt; There can be problems relocating the DB if it takes too long to<br>
&gt; start/shutdown. If you are having problems relocating with luci it may<br>
&gt; be a good idea to test with:<br>
&gt;<br>
&gt; # clusvcadm -r &lt;service name&gt; -m &lt;cluster node&gt;<br>
&gt;<br>
&gt; -Ben<br>
&gt;<br>
&gt;<br>
&gt;<br>
&gt;<br>
&gt;<br>
&gt;<br>
&gt; ----- &quot;fosiul alam&quot; &lt; <a href="mailto:expertalert@gmail.com">expertalert@gmail.com</a> &gt; wrote:<br>
&gt;<br>
&gt; &gt; Hi<br>
&gt; &gt; I have 4 nodes cluster,<br>
&gt; &gt; It was running fine. but today one nodes is giving trouble<br>
&gt; &gt;<br>
&gt; &gt; From luci Gui interface, when i try to relocate service into this<br>
&gt; node<br>
&gt; &gt; and trying to relocate from this nodes to another nodes<br>
&gt; &gt;<br>
&gt; &gt; from luci gui interface, its showing :<br>
&gt; &gt;<br>
&gt; &gt; Unable to retrieve batch 1908047789 status from<br>
&gt; &gt; beaver.domain.local:11111: clusvcadm start failed to start httpd1:<br>
&gt; &gt; Starting cluster service &quot;httpd1&quot; on node &quot;http1.domain.local&quot; --<br>
&gt; You<br>
&gt; &gt; will be redirected in 5 seconds.<br>
&gt; &gt; also<br>
&gt; &gt;<br>
&gt; &gt; The ricci agent for this node is unresponsive. Node-specific<br>
&gt; &gt; information is not available at this time. :<br>
&gt; &gt;<br>
&gt; &gt; but ricci is running on problematic node ,<br>
&gt; &gt; ricci 7324 0.0 0.1 58876 2932 ? S&lt;s 14:40 0:00 ricci -u 101<br>
&gt; &gt;<br>
&gt; &gt; there is not any firewall running.<br>
&gt; &gt;<br>
&gt; &gt; iptables -L<br>
&gt; &gt; Chain INPUT (policy ACCEPT)<br>
&gt; &gt; target prot opt source destination<br>
&gt; &gt;<br>
&gt; &gt; Chain FORWARD (policy ACCEPT)<br>
&gt; &gt; target prot opt source destination<br>
&gt; &gt;<br>
&gt; &gt; Chain OUTPUT (policy ACCEPT)<br>
&gt; &gt; target prot opt source destination<br>
&gt; &gt;<br>
&gt; &gt; Chain RH-Firewall-1-INPUT (0 references)<br>
&gt; &gt; target prot opt source destination<br>
&gt; &gt;<br>
&gt; &gt; port 11111 is runningg<br>
&gt; &gt;<br>
&gt; &gt; netstat -an | grep 11111<br>
&gt; &gt; tcp 0 0 <a href="http://0.0.0.0:11111" target="_blank">0.0.0.0:11111</a> 0.0.0.0:* LISTEN<br>
&gt; &gt;<br>
&gt; &gt;<br>
&gt; &gt; but still ricci is very unstable , and i cant relocate any service<br>
&gt; on<br>
&gt; &gt; this node or i cant relocate any service away from this node.<br>
&gt; &gt;<br>
&gt; &gt; from problematic node if i type this<br>
&gt; &gt;<br>
&gt; &gt; clustat<br>
&gt; &gt; Cluster Status for ng1 @ Thu Sep 23 20:24:02 2010<br>
&gt; &gt; Member Status: Quorate<br>
&gt; &gt;<br>
&gt; &gt; Member Name ID Status<br>
&gt; &gt; ------ ---- ---- ------<br>
&gt; &gt; beaver.xxx.local 1 Online, rgmanager ::: luci is running from this<br>
&gt; &gt; server publicdns1.xxxx.local 2 Online, rgmanager<br>
&gt; &gt; http1.xxxx.local 3 Online, Local, rgmanager<br>
&gt; &gt; mail01.xxxxx.local 4 Online, rgmanager<br>
&gt; &gt;<br>
&gt; &gt; Service Name Owner (Last) State<br>
&gt; &gt; ------- ---- ----- ------ -----<br>
&gt; &gt; service:httpd1 mail01.xxxx.local started<br>
&gt; &gt; service:mysql-server http1.xxxx.local started -------------------<br>
&gt; this<br>
&gt; &gt; is the problematic node<br>
&gt; &gt; service:public-dns publicdns1.xxxxxx.local started<br>
&gt; &gt;<br>
&gt; &gt; I cant move that service mysql-server from this node or cant<br>
&gt; relocate<br>
&gt; &gt; any service on this node ..<br>
&gt; &gt; I am very confused.<br>
&gt; &gt;<br>
&gt; &gt; what shall i do to fix this issue ??<br>
&gt; &gt;<br>
&gt; &gt; thanks for your advise.<br>
&gt; &gt;<br>
&gt; &gt;<br>
&gt; &gt;<br>
&gt; &gt;<br>
&gt; &gt; -- Linux-cluster mailing list<br>
&gt; &gt; <a href="mailto:Linux-cluster@redhat.com">Linux-cluster@redhat.com</a><br>
&gt; &gt; <a href="https://www.redhat.com/mailman/listinfo/linux-cluster" target="_blank">https://www.redhat.com/mailman/listinfo/linux-cluster</a><br>
&gt;<br>
&gt; -- Linux-cluster mailing list<br>
&gt; <a href="mailto:Linux-cluster@redhat.com">Linux-cluster@redhat.com</a><br>
&gt; <a href="https://www.redhat.com/mailman/listinfo/linux-cluster" target="_blank">https://www.redhat.com/mailman/listinfo/linux-cluster</a><br>
&gt;<br>
&gt;<br>
&gt; -- Linux-cluster mailing list<br>
&gt; <a href="mailto:Linux-cluster@redhat.com">Linux-cluster@redhat.com</a><br>
&gt; <a href="https://www.redhat.com/mailman/listinfo/linux-cluster" target="_blank">https://www.redhat.com/mailman/listinfo/linux-cluster</a><br>
<br>
-- Linux-cluster mailing list<br>
<a href="mailto:Linux-cluster@redhat.com">Linux-cluster@redhat.com</a><br>
<a href="https://www.redhat.com/mailman/listinfo/linux-cluster" target="_blank">https://www.redhat.com/mailman/listinfo/linux-cluster</a><br>
<br>
<br>
</div></div>-- Linux-cluster mailing list<br>
<div><div></div><div class="h5"><a href="mailto:Linux-cluster@redhat.com">Linux-cluster@redhat.com</a><br>
<a href="https://www.redhat.com/mailman/listinfo/linux-cluster" target="_blank">https://www.redhat.com/mailman/listinfo/linux-cluster</a><br>
<br>
--<br>
Linux-cluster mailing list<br>
<a href="mailto:Linux-cluster@redhat.com">Linux-cluster@redhat.com</a><br>
<a href="https://www.redhat.com/mailman/listinfo/linux-cluster" target="_blank">https://www.redhat.com/mailman/listinfo/linux-cluster</a><br>
</div></div></blockquote></div><br>