<div><br></div>selinux is in Enforced mode ( worth checking audit.log ) ? .If yes, try selinux to permissive or disabled mode and check . <div><div><br></div><div>Regards, <br><br><div class="gmail_quote">On Thu, Jun 16, 2011 at 1:48 PM, Corey Kovacs <span dir="ltr">&lt;<a href="mailto:corey.kovacs@gmail.com">corey.kovacs@gmail.com</a>&gt;</span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">My appologies for not getting back sooner. I am in the middle of a move.<br>
<br>
I cannot post my configs or logs (yeah, not helpful I know) but<br>
suffice it to say I strongly believe they are correct (I know,<br>
everyone says that). I&#39;ve had other people look at them just make sure<br>
it wasn&#39;t a case of proofreading my own paper etc. and it always comes<br>
down to the umount failing. I have 6 other identical NFS services<br>
(save for the mount point/export location) and they all work<br>
flawlessly. That&#39;s why I am zeroing in on the use of &#39;/home&#39; as the<br>
culprit.<br>
<br>
Anyway, it&#39;s not a lot to go on I know, but I am just looking for<br>
directions to search for now.<br>
<br>
Thanks<br>
<font color="#888888"><br>
Corey<br>
</font><div><div></div><div class="h5"><br>
On Mon, Jun 13, 2011 at 11:44 AM, Rajveer Singh<br>
&lt;<a href="mailto:torajveersingh@gmail.com">torajveersingh@gmail.com</a>&gt; wrote:<br>
&gt;<br>
&gt;<br>
&gt; On Thu, Jun 9, 2011 at 8:22 PM, Corey Kovacs &lt;<a href="mailto:corey.kovacs@gmail.com">corey.kovacs@gmail.com</a>&gt; wrote:<br>
&gt;&gt;<br>
&gt;&gt; Folks,<br>
&gt;&gt;<br>
&gt;&gt; I have a 5 node cluster serving out several NFS exports, one of which is<br>
&gt;&gt; /home.<br>
&gt;&gt;<br>
&gt;&gt; All of the nfs services can be moved from node to node without problem<br>
&gt;&gt; except for the one providing /home.<br>
&gt;&gt;<br>
&gt;&gt; The logs on that node indicate the umount is failing and then the<br>
&gt;&gt; service is disabled (self-fence is not enabled).<br>
&gt;&gt;<br>
&gt;&gt; Even after the service is put into a failed state and then disabled<br>
&gt;&gt; manually, umount fails...<br>
&gt;&gt;<br>
&gt;&gt; I had noticed recently while playing with conga that creating a<br>
&gt;&gt; service for /home on a test cluster a warning was issued about<br>
&gt;&gt; reserved words and as I recall (i could be wrong) /home was among the<br>
&gt;&gt; illegal parameters for the mount point.<br>
&gt;&gt;<br>
&gt;&gt; I have turned everything off that I could think of which might be<br>
&gt;&gt; &quot;holding&quot; the mount and have run the various iterations of lsof, find<br>
&gt;&gt; etc. nothing shows up as having anything being actively used.<br>
&gt;&gt;<br>
&gt;&gt; This particular file system is 1TB.<br>
&gt;&gt;<br>
&gt;&gt; Is there something wrong with using /home as an export?<br>
&gt;&gt;<br>
&gt;&gt; Some specifics.<br>
&gt;&gt;<br>
&gt;&gt; RHEL5.6 (updated as of last week)<br>
&gt;&gt; HA-LVM protecting ext3 using the newer &quot;preferred method&quot; with clvmd<br>
&gt;&gt; Ext3 for exported file systems<br>
&gt;&gt; 5 nodes.<br>
&gt;&gt;<br>
&gt;&gt;<br>
&gt;&gt; Any ideas would be greatly appreciated.<br>
&gt;&gt;<br>
&gt;&gt; -C<br>
&gt;&gt;<br>
&gt; Can you share your log file and cluster.conf file<br>
</div></div><div><div></div><div class="h5">&gt; --<br>
&gt; Linux-cluster mailing list<br>
&gt; <a href="mailto:Linux-cluster@redhat.com">Linux-cluster@redhat.com</a><br>
&gt; <a href="https://www.redhat.com/mailman/listinfo/linux-cluster" target="_blank">https://www.redhat.com/mailman/listinfo/linux-cluster</a><br>
&gt;<br>
<br>
--<br>
Linux-cluster mailing list<br>
<a href="mailto:Linux-cluster@redhat.com">Linux-cluster@redhat.com</a><br>
<a href="https://www.redhat.com/mailman/listinfo/linux-cluster" target="_blank">https://www.redhat.com/mailman/listinfo/linux-cluster</a><br>
</div></div></blockquote></div><br></div></div>