<br>Hi,<br><br>Btw, how many HBAs are present in your box ? . Problem is with scsi3 only ?. <br>Refer <a href="https://access.redhat.com/kb/docs/DOC-2991">https://access.redhat.com/kb/docs/DOC-2991</a> , then set the filter. <br>
Also, I would suggest you to open ticket with Linux vendor if IO errors are belongs to Active paths. <br><br>Pointed IO errors are belongs to disk that in passive paths group ?. you can verify the same in multipath-ll output .<br>
<br>regards,<br><br><div class="gmail_quote">On Sun, Jun 19, 2011 at 10:03 PM, dOminic <span dir="ltr">&lt;<a href="mailto:share2dom@gmail.com">share2dom@gmail.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">
Hi Balaji,<div><br></div><div>Yes, the reported message is harmless ... However, you can try following </div><div><br></div><div>1) I would suggest you to set the filter setting in lvm.conf to properly scan your mpath* devices and local disks. </div>

<div>2) Enable blacklist section in multipath.conf  eg:</div><div><br></div><div><div>blacklist {</div><div>       devnode &quot;^(ram|raw|loop|fd|md|dm-|sr|scd|st)[0-9]*&quot;</div><div>       devnode &quot;^hd[a-z]&quot;</div>

<div>}</div></div><div><br></div><div># multipath -v2 </div><div><br></div><div>Observe the box. Check whether that helps ...</div><div><br></div><div><br></div><div>Regards, </div><div><br><br><div class="gmail_quote"><div>
<div></div><div class="h5">On Wed, Jun 15, 2011 at 12:16 AM, Balaji S <span dir="ltr">&lt;<a href="mailto:skjbalaji@gmail.com" target="_blank">skjbalaji@gmail.com</a>&gt;</span> wrote:<br>
</div></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div><div></div><div class="h5">Hi,<div>In my setup implemented 10 tow node cluster&#39;s which running mysql as cluster service, ipmi card as fencing device.</div>

<div><br></div><div>In my /var/log/messages i am keep getting the errors like below,</div>
<div><br></div><div><div>Jun 14 12:50:48 hostname kernel: end_request: I/O error, dev sdm, sector 0</div><div>Jun 14 12:50:48 hostname kernel: sd 3:0:2:2: Device not ready: &lt;6&gt;: Current: sense key: Not Ready</div><div>


Jun 14 12:50:48 hostname kernel:     Add. Sense: Logical unit not ready, manual intervention required</div><div>Jun 14 12:50:48 hostname kernel: </div><div>Jun 14 12:50:48 hostname kernel: end_request: I/O error, dev sdn, sector 0</div>


<div>Jun 14 12:50:48 hostname kernel: sd 3:0:2:4: Device not ready: &lt;6&gt;: Current: sense key: Not Ready</div><div>Jun 14 12:50:48 hostname kernel:     Add. Sense: Logical unit not ready, manual intervention required</div>


<div>Jun 14 12:50:48 hostname kernel: </div><div>Jun 14 12:50:48 hostname kernel: end_request: I/O error, dev sdp, sector 0</div><div>Jun 14 12:51:10 hostname kernel: sd 3:0:0:1: Device not ready: &lt;6&gt;: Current: sense key: Not Ready</div>


<div>Jun 14 12:51:10 hostname kernel:     Add. Sense: Logical unit not ready, manual intervention required</div><div>Jun 14 12:51:10 hostname kernel: </div><div>Jun 14 12:51:10 hostname kernel: end_request: I/O error, dev sdc, sector 0</div>


<div>Jun 14 12:51:10 hostname kernel: printk: 3 messages suppressed.</div><div>Jun 14 12:51:10 hostname kernel: Buffer I/O error on device sdc, logical block 0</div><div>Jun 14 12:51:10 hostname kernel: sd 3:0:0:2: Device not ready: &lt;6&gt;: Current: sense key: Not Ready</div>


<div>Jun 14 12:51:10 hostname kernel:     Add. Sense: Logical unit not ready, manual intervention required</div><div>Jun 14 12:51:10 hostname kernel: </div><div>Jun 14 12:51:10 hostname kernel: end_request: I/O error, dev sdd, sector 0</div>


<div>Jun 14 12:51:10 hostname kernel: Buffer I/O error on device sdd, logical block 0</div><div>Jun 14 12:51:10 hostname kernel: sd 3:0:0:4: Device not ready: &lt;6&gt;: Current: sense key: Not Ready</div><div>Jun 14 12:51:10 hostname kernel:     Add. Sense: Logical unit not ready, manual intervention required</div>


</div><div><br></div><div><br></div><div>when i am checking the multipath -ll , this all devices are in passive path.</div><div><br></div><div>Environment :</div><div><br></div><div>RHEL 5.4 &amp; EMC SAN</div><div><br></div>


<div>Please suggest how to overcome this issue. Support will be highly helpful.</div><div>Thanks in Advance</div><div> <br clear="all"><br>-- <br>Thanks,<br>BSK<br>
</div>
<br></div></div>--<br>
Linux-cluster mailing list<br>
<a href="mailto:Linux-cluster@redhat.com" target="_blank">Linux-cluster@redhat.com</a><br>
<a href="https://www.redhat.com/mailman/listinfo/linux-cluster" target="_blank">https://www.redhat.com/mailman/listinfo/linux-cluster</a><br></blockquote></div><br></div>
</blockquote></div><br>