[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[linux-lvm] vgcreate core dumps



I'm perplexed.

here's what happened
==========================
# fdisk /dev/sdb

Command (m for help): p

Disk /dev/sdb: 255 heads, 63 sectors, 553 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/sdb1             1       553   4441941   8e  Unknown

Command (m for help): q

# pvcreate /dev/sdb1
pvcreate -- reinitializing physical volume
pvcreate -- physical volume "/dev/sdb1" successfully created

# vgcreate test_vg /dev/sdb1
Segmentation fault (core dumped)
=======================
here's the state of my machine

=======================
# cat /proc/lvm
LVM module version 0.8i  (02/10/1999)

Total:  0 VGs  0 PVs  0 LVs (0 LVs open)
Global: 140 bytes vmalloced   IOP version: 5   0:04:12 active

# uname -r
2.3.33

# lsmod
Module                  Size  Used by
lvm                    99920   0 
3c509                   7188   1  (autoclean)

# vgcreate --help
vgcreate: invalid option -- -

Logical Volume Manager 0.8 by Heinz Mauelshagen  17/09/1999
<snipped, just looking for version>
======================

I've also tried with the partition type set to 0xfe
with the same results. I've tried using the lvm module
and with lvm compiled directly into the kernel, with the 
same results.

I'm obviously missing something here.  I just don't know what it is.

thanks for any help

-- 
Rob

Attachment: pgp00000.pgp
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]