[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[linux-lvm] invalid i/o protocol version



Hi there,

I get this error while running vgscan:

# vgscan -vd
lvm_get_iop_version -- CALLED
lvm_get_iop_version -- AFTER ioctl ret: 0
lvm_get_iop_version -- LEAVING with ret: 0
vgscan -- invalid i/o protocol version

As a saw in the mail archives, it could be a missing /dev/lvm, but it is there:

# ls -l /dev/lvm
crw-r-----   1 root     root     109,   0 Apr 29 03:35 /dev/lvm

I tried a few kernels to see if that was the problem, but still haven't found what is wrong.

Is it the lvm-0.8-11.rpm that I use? For some reason I can't compile the tools in tar files (tried different version, all the same errors on "function basename").

# dmesg | grep -i lvm
LVM version 0.8final  by Heinz Mauelshagen  (15/02/2000)
lvm -- Driver successfully initialized

Is the rpm file compatible with this version (it installed without problems)?

At the moment I use Redhat 6.0 with upgraded kernel 2.3.99-pre6.

Hope somebody can help me.

Harrie



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]