[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [linux-lvm] vgscan does not found my VG, but pvscan does...

On Wednesday 25 April 2001 05:20, you wrote:
> Hash: SHA1
> Have you tried a vgimport?

Yes I did. vgimport does not want to import the VG, because it is not an 
exported one :((.

On an other machine I had the same problem and I tried to make a vgexport.
The _export_ went well (the VG was exported but I could not re-import it ).

I tried some things last night... 
  - First I have saved the heder blocks (VGDA) with dd (dd if=/dev/sda1   \
     of=/root/HEAD_sda1 count=4596 bs=512) 
  - Then I called a vgcfgrestore -n sysvg /dev/sda1.
  - Now pvscan tells me both PVs are in the VG sysvg. 
  - "vgchange -ay sysvg" activated the VG and the LVs could me mounted 

  - vgscan does NOT find the sysvg!!!
  - After a reboot the sysvg is not available.
  - Every time I have to call a vgcfgrestore :((

I have written a C-program which could retrieve all data from a LV, if pvdata 
-E reports correctly, but the LV could not be activated. But this is only a 
very bad work arround to retrieve my data. But I need a way to reactivate my 
VG, so it could be found by vgscan.

I'm hopeful we will find a solution.
Fabian Herschel

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]