[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [linux-lvm] 0.8 to 0.9 problems, odd vg corruption



On Sat, Dec 30, 2000 at 03:11:06PM -0600, Steven Lembark wrote:
> 
> > After about half an hour of fiddling with the LVM tools and reading the
> > FAQ, I found out that I could access the LV if and ONLY IF I did EXACTLY
> > this:
> > 
> >         vgcfgrestore -n data /dev/hd[ac]1
> >         pvscan
> >         vgchange -a y
> >         mount /dev/data/archive
> > 
> > Any call to vgscan brings me back to the beginning ("unknown VG").
> > 
> > The problem however is this: Since then, even when booting cleanly vgscan
> > doesn't detect any VGs any more. Before, it worked. I have compiled LVM
> > into the kernel (no module) and attached the Debian startup script which I
> > have modified slightly to accommodate for the no-module situation.
> 
> 
> try:
> 
> 	vgexport /dev/vgname;
> 	vgimport /dev/vgname /devices/in/the/vg;
> 
> should save you the problems.  

I should have tried that, however I did "fix" the problem by copying the data
elsewhere (it's on a large external RAID device, so I just created a new
temporary vg/lv), deleting the original VG, re-creating and copying back.  All
appears to be well.

-- 
Jesse Sipprell
Technical Operations Director
Evolution Communications, Inc.
800.496.4736

* Finger jss evcom net for my PGP Public Key *


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]