[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [linux-lvm] unable to import vg in 2.4.1pre7




Gustavo Zacarias wrote:


Joakim Recht wrote:


I wanted to upgrade from 2.4.0pre13 to 2.4.1pre7, so I vgexported my vg,
rebooted, installed new tools and tried to vgimport the volume, but this
just gives me this error:

vgimport -- ERROR: couldn't create VGDA for imported volume group
"volgroups" in kernel

I've used the 0.9.1beta1 tools from cvs and the patch 2.4.1pre7 patch
posted here earlier today. Any solution to this?


Sorry Sorry Sorry!
Actually the patch i made up, which is a total hack and shouldn't
trust for more than testing, is based on 0.9 with fixes from cvs.
Remember, it's NOT offical, and certainly NOT from the LVM people.
Mea culpa: this happens when i lack caffeine during long periods
of code tweaking...

I'm perfectly aware of this... It was just the easiest way of patching to pre7, as we have almost the same setup. However, if I patch it manually (with the vgextend patch), I get the same error, so the question is still there.

--
Joakim Recht
Tlf. 20 85 54 77
Email god cs auc dk
WWW http://www.braindump.dk / http://www.compuclub.dk



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]