[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[linux-lvm] Updating from Suse Linux 6.4 to Suse Linux 7.0 with LVM



Hello,

I am trying to update Suse Linux 6.4 to Suse Linux 7.0 Professional. I have all
my file systems except /boot and / and swap under lvm.

When I try to use Suse's yast1, it doesn't recognize and mount my lvm based file
systems. Suse writes on its support page, that the lvm version coming with the
7.0 does not recognize lvm partitions in an Win98 extended partition, which is
the case with me and that I should install a newer version of lvm.

When I am trying to reimport the exported vg (vgimport vgxy /dev/hdaz) I always
get a read error -256 on that partition. Based on that I think that it is still
using the old lvm library, even though I use the executables from the new
version of lvm.

Now my problem is, how do I make Linux Suse 7.0 on CD use that new lvm. When I
try to load liblvm.so e.g. by creating a ld.so.preload, I get an error about an
undefined symbols and I cannot do anything after that. I also get messages about
undefined symbols when I try to load the module lvm.o with insmod.

I am lost on how to mount my lvm partitions. 

I do not want to install everyth8ing from scratch.

Thanks in advance

Dieter Wörz
-- 
Dieter Wörz                                        Tel: +49 711  17 49717
debis Systemhaus Industry                          Tel: +49 7031 90 81141
Engineering Data Management EDM/S                  Fax: +49 711  17 40331
Erich-Herion-Strasse 13                            
D 70736 Fellbach                                   Mail: Dieter Woerz debis com


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]