[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [linux-lvm] Raid5 sync problem



You are running off of parity. Until you get that drive fixed, it will
hurt.

-- 
Austin Gonyou
Systems Architect, CCNA
Coremetrics, Inc.
Phone: 512-796-9023
email: austin coremetrics com

On Thu, 24 May 2001, Kaj-Michael Lang wrote:

> I'm mailing this to the LVM list as it might also be the cause of this.. I
> don't know.
>
> Anyway I have 4 6g drives in a RAID5 configuration. On top the md device I
> have a VG and a couple of LV in it. I'm running 2.4.4 with the beta7 LVM
> patch and using ext2 on all the LV's.
> It now happened that one drive failed (actually just a IDE cable problem but
> anyway) and the machine became really really slow. Load was up to 200 and
> almost every command got stuck so all I could do was to boot.
> It came up ok, and I hotadded the drive back and it started to sync but
> after a while the sync was down to 0 kb/sec and the same slow-down started
> to happen.
> So I boot again.. and now when it started to fsck the LV's it slowed-down
> again. So I booted with init=/bin/bash and let the sync finnish without any
> other access to the RAID/LV's and after that everything worked fine again.
>
> So the problem seems to be that when accessing the RAID5 while it is syncing
> locks somewhere. Does anyone know of a fix or know what I should do so that
> syncing won't kill the machine.
>
>
> Kaj-Michael Lang
> milang tal org
> Java? I've heard of it, it is what I drink while hacking PHP!
>
> _______________________________________________
> linux-lvm mailing list
> linux-lvm sistina com
> http://lists.sistina.com/mailman/listinfo/linux-lvm
> read the LVM HOW-TO at http://www.sistina.com/lvm/Pages/howto.html
>



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]